Jump to content

The Psu Is The Most Important Of All


Recommended Posts

i had a vigor XG 500watt psu....well all was well till today at the 75person lan in our area....needless to say i get goin for about 1 hour...then blackness...and it vainly tires to start up....sadly....it couldnt continue...i shorted the green and black wires just to make sure it was the PSU...and it was...luckily for me the LAN was at a PC store so i picked up a Ultra X-connect for 70bux.....THE LESSON IS>>>>>>YOU GET WHAT YOU PAY FOR AND DONT PAY FOR LOOKS ALONE!!!!!!! (i was soooo lucky it didnt kill my processor or 6800ultra...or ne other components) phewww.....

Share this post


Link to post
Share on other sites

First off that MGE PSU is pretty crappy as you have already discovered.

i picked up a Ultra X-connect for 70bux.....THE LESSON IS>>>>>>YOU GET WHAT YOU PAY FOR AND DONT PAY FOR LOOKS ALONE!!!!!!!

Sorry to burst your bubble but the X-Connect PSU isn't that much better compared to your MGE in terms of quality.

Share this post


Link to post
Share on other sites

Any psu can die on you, the important part is that it should have all the protection a good ps has, so basically if it protects your devices when it dies, and has stable rails, it's a good psu :lol:

Share this post


Link to post
Share on other sites

First off that MGE PSU is pretty crappy as you have already discovered.

 

Sorry to burst your bubble but the X-Connect PSU isn't that much better compared to your MGE in terms of quality.

429297[/snapback]

 

 

:withstupid: , you should get a psu from a reliable brand

Share this post


Link to post
Share on other sites

Actually, my X-Connect is a very SOLID very good quality psu. I keep hearing people over and over again about how it is a just for the looks psu but I disagree. maybe I got a good one because I got one of the earlier ones I don't know.

Share this post


Link to post
Share on other sites

i got one too, i had to take back 2 thermaltake 480wt butterfly's within 2 months cuz the 12vt rails were at 11.8 and would taper off causing my system to hang. then i got an enermax noisetaker and it was good but not near enough connectors. i get this x-connect, problems solved.

Edited by sYstEmATiC

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...