Jump to content
Sign in to follow this  
ARandomOWL

FAH Affinity Setter

Recommended Posts

Glad it's been of use :) I haven't updated it in a while, I may see if anything needs updating or I might give away the source code so someone else can continue to develop it.

Share this post


Link to post
Share on other sites

MAJOR UPDATE Includes:

 

Changed name to [email protected] Manager

Ability to set priority

Second GPU capability

Added tab to run & kill clients, etc. (not yet functional, hope to get it working soon)

 

For more infos see change log.txt in the download.

 

Note: This release has not yet been fully tested, please ensure priorities are being set right using task manager. If they are right the first few times it is safe to stop chacking.

 

Note 2: Kingdingaling has noticed that this program must be started first before any [email protected] clients. This may not be the case for all machines.

 

[email protected] Manager 1.12 (.zip, 29.7KB)

Share this post


Link to post
Share on other sites

The priority is being set correctly on my rig, I got both the GPU2 clients on Realtime and the CPU client on low.

 

Regarding the starting the starting this program first bit, if you have the clients running and then start this program, it will use 100% of one core and hang there until you shut it down with the Task Manager. This is what happened on my machine, but the very simple way to combat that is to start the [email protected] Manager first, let it sit in the tray for a couple of second, then open it, set it up as you like it, and only then fire up the [email protected] clients.

 

Works great, thanks for adding the dual GPU2 clients feature! :)

Share this post


Link to post
Share on other sites

I founnd a bug if you want, you can't run all clients real time. I tried running the CPU and both GPU clients on real time, that gave me about 83% CPU usage maximum, but as soon as I set the CPU client down to High, it went back to 100%. Also, all clients on Realtime might cause the computer to freeze. After it only used 83%, my rig crashed twice in a row.

Share this post


Link to post
Share on other sites

Well it's common sense really not to set all clients to realtime. Nothing really should be set to realtime. Do u suggest to put a limitation on the priority? Say disable realtime? or only allow one to be set to realtime?

 

Thx for spotting that. Ur helping to make my program better :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×