Jump to content
Sign in to follow this  
RadioActivated

VERY slow transfer speed (external to external)

Recommended Posts

Hey guys,

I have 2 Seagate USB3.0 external drives (1x2TB & 1x6TB) and I am trying to transfer 1TB of stuff from one drive to another. The transfer speed is ~3mb per second and it says it's gonna take more than 1 day, what the heck is going one? My MB drivers are brand new, so what can be the problem?

AMD 3900X 9

ASUS X570 PLUS GAMING

32GB VENGEANCE RAM

GEFORCE 2070 SUPER RTX

750W SEASONIC GOLD+

Share this post


Link to post
Share on other sites

Well it should go at 100 MB/s or higher. Do you have the chipset drivers installed? I know it sounds stupid but if you don't have the right drivers than it reverts to USB 2.0 and uses Windows defaults ones. 

The other option is one drive is bad, which is why the read (or write) speed is so low. I guess it also could be if you are copying lots of little files than it will give you a false number. Try copying one big file and see if goes. Lots of choices....

Share this post


Link to post
Share on other sites
5 hours ago, ir_cow said:

Well it should go at 100 MB/s or higher. Do you have the chipset drivers installed? I know it sounds stupid but if you don't have the right drivers than it reverts to USB 2.0 and uses Windows defaults ones. 

The other option is one drive is bad, which is why the read (or write) speed is so low. I guess it also could be if you are copying lots of little files than it will give you a false number. Try copying one big file and see if goes. Lots of choices....

Installed latest chipset driver, getting 60-70mbps, much better!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×