Jump to content

Wi-fi Problem


Ronin
 Share

Recommended Posts

It's been a long time since I've posted, I've barley touched a computer for almost 2 years and moved to France. Long story short I'm working in an office now and have been encountering strange annoying problems with the wireless network.

 

Someone asked me a few weeks ago if I could get one of the computers up on wireless, normally not very hard. So I installed a D-link GWL 520+, installed the XP drivers(OS=Windows XP SP2), semmed successful. I then brought up the adapter properties, put in the WEP key, set it to shared, blah blah. Normal installation. I finshed clicked okay and windows sent out a dhcp broadcast. I waited a minute and then it said that it couldn't get an address. Strange... I verfied my WAP settings and my router settings, WAP is set to run a bit like a hub, the router is setup to give addresses(normal dhcp w/NAT setup). I went back to the computer and lo-and behold it had found an address. Ipconfig shows that all the information is correct, (ip address, subnet, gateway, dns server) all the addresses match the other computer's config(except the ip...for obvious reasons) so I figured I had won, I tried to ping the gateway and no go. Strange, I have addresses, windows says I'm connected. Try to ping around, in the network outside the network etc. Nothing. Then the connection drops, comes back up, says no address can be obtained and then gets one after a minute anyway and I can't connect.

 

So there's the problem, the solutions I've tried include but are not limited to:

-re-doing configuration process(everything but reinstalling the drivers)

 

-checked the WAP to make sure that MAC address filtering was turned off, got frustrated and spoofed the mac address from another wireless computer on the network and turned that computer off(to insure no conflicts) with no success.

 

-installed the VIA 4 in 1 drivers and ran windows update

 

-Tried diffrent settings in the NIC properties(shared vs open, manually setting all address vs DHCP, set key vs key automatically obtained)

 

-Verified that I could have a wired connection by getting a really really long network cable and plugging it in.

 

-verified WEP key several times, thought maybe I was making a mistake so I disabled WEP alltogether on the WAP and tried connecting without encryption without success(same problem)

 

-verfied that there wasn't interference using netstumbler, I have very little interference.

 

-Disabled windows firewall aswell as all other firewalls they had installed

 

-rebooted

 

-Thought there might be a problem with the NIC so I put it on another computer and installed it on the secure network in <2mins.

 

-Loaded up knoppix STD to see if I could get it up that way, unfortunatly I didn't find support for my card, I heard knoppix auditor supports it so I may try that a bit later

 

Here are my remaning idea's:

-Try a diffrent OS(knoppix auditor) or maybe mandrake if I get around to partitioning the hdd

-Try a diffrent NIC, I have one and haven't had time to try it yet

-Reinstall current NIC

 

 

There you have it, I kinda feel like I've tried everything(except those 3 things which have little hope of success) So just to recap, I'm connected to the WAP, but can't ping anything even though DHCP gives me an address sometimes I can ping the WAP and I can always ping myself(thats generally true under any circomstance)

 

Any help or any idea's anyone could offer would be greatly appreciated. I think this is a pretty good resum

Edited by Ronin

Share this post


Link to post
Share on other sites

after reading your other post, I will bump this up for you, now that it's at a more reasonable time of day ;) (though the evening, night time seems to be the most active).

 

Unfortunately I have no experience with Wi-Fi, so I can't help you out more than my bumping <_>

Share this post


Link to post
Share on other sites

totally uninstall the drivers from the computer for that piece of hardware "the wireless NIC" then reinstall them.. if that dont work try a system restore before the actual card was installed if possable... do all the latest windows updates... i was having a similar problem.. idk what worked.. it just finally worked.. even static ip was not working, but the card was getitng a privitally asigned ip and was never getting an address from my dchp server..

Share this post


Link to post
Share on other sites

I've now reinstalled the NIC without success, I'll try using system restore.

 

I keep on having the feeling that I must be doing something small and stupid but I did get it working on another comp in like 2 minutes...I guess that assures me but doesn't really help.

 

Maybe I should just buy a WAP/Router and run NAT inisde the network, have 2 LAN's, its sloppy and its overkill but it would probably work. It's too bad the DWL 520+ isn't supported with knoppix. I miss my old Dell mobile card with a hacked firmware so that it would run like an orinoco gold. ah the good 'ol days.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...