Jump to content

Mobo will not boot error 75

Recommended Posts

This happed a few times in the past but after a 2nd restart it would load fine. Now this morning I did a restart on the pc but it wont load.


I seem to be getting stuck on ASRock Boot logo screen. I can't get into the bios or any buttons to function, I think it is freezing on this.


I have tried to power it off and let it set for a few mins, no difference.

I tried to clear the cmos w/ the handy clear cmos button, no diffrence


The debug LED reads 75 and stays that way. The manual reads "Initialize Int-13 and prepare for IPL detection." is what that means. I dont know what int-13 or IPL is.


Im not really sure what todo.


I did add a SSD yesterday, I prob reboot the computer w/ zero issues serveral times after that. (thinking this might be the issue I removed the SSD this morning, no difference)


Like I said this has happend a few times in the past but it would sort of sort its self out.


I hope you guys can help me solve this one.


System specs

Mobo : Asrock x58 extreme

Ram : G.SKILL 6GB (3 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800)

cpu : i7 920

SSD : 120 gig ocz vertex

HHD : 1TB Samsung 7500rpm

GPU : HD 5870


not sure what else helps


ps : I had been hoping to build a new rig next year w/ the new ivy chips coming hoping this one will last. I am starting to think my current mobo is toast.


I asked on other forums and people still recomend I buy asrock. Im really iffy about this as I have RMA'd my current motherboard 3 times for it dying randomly. I know if it is just this mobo in general or if asrock is lackluster quality. I know I have been waiting about 2 weeks for a replay from them on this current issue. I didn't come on here however to bash the company so please don't take this out of context Im just curious how other feel about current Asrock products. There price is great on all the features im just worried about them because the terrible "luck" I have had on the current one I own.

Share this post

Link to post
Share on other sites

HI mate,


Firstly I want to say welcome to OCC and I hope you find this place helpful. We are happy to have you on board.


PSU info would be helpful to add. You tried updating BIOS?

This thread and this thread might be of help - sounds like a similar problem.


So it looks like "75 = Initialize Int-13 and prepare for IPL detection." from your manual means that this is the stage in the booting checklist that it gets to before dying.


Going by what I've seen in the two above threads and elsewhere, I would look to the PSU and your HDD connections for problems.


1) First thing I would do is check everything in your computer. Is everything plugged in right? All things powered up? Everything seated right? Is your new SSD plugged in correctly?


2) If all that is good and it still fails try removing components and see if you can get it working at bare bones.


3) If it doesn't work at bare minimum hardware then you might need to try a different PSU if you have one handy.

3.1 - If it does work at bare minimum, then keep adding back your hardware components one by one until you get the error again and that might tell you what is to blame.


4) If it still doesn't work with a different PSU and you have latest bios then it might be that your board is in for another RMA unfortunately.


See how you go.

Edited by Alexandre

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...