Jump to content


Photo
- - - - -

Red Alert 2 In a Window


  • Please log in to reply
5 replies to this topic

#1 Tylosis

Tylosis

    Member

  • Members
  • PipPip
  • 58 posts

Posted 10 August 2006 - 10:09 PM

Hey all, I was sifting through my old games recently, and came across Red Alert 2. I have a very large monitor so the game running at 1024 x 768 looks like utter crap...

Does anyone know if I can run the game in a window? If so, how?

I've played other games where you can manually set it to windowed by adding -w to the command line for the shortcut, but for Red Alert 2 it didn't work...

#2 petercintn

petercintn

    Member

  • Members
  • PipPip
  • 183 posts

Posted 11 August 2006 - 10:21 PM

Your doing better than me, I can't get it to run period. Ever since I upgraded to this rig. Did you do anything or just not have any problems with the game?

#3 Tylosis

Tylosis

    Member

  • Members
  • PipPip
  • 58 posts

Posted 12 August 2006 - 12:55 AM

Yeah, I just installed it and ran it just fine totally unpatched.

Just wish I could get it to run windowed :confused:

#4 Cooler

Cooler

    Member

  • Members
  • PipPip
  • 181 posts
  • Gender:Male

Posted 15 August 2006 - 06:35 AM

I have a very large monitor so the game running at 1024 x 768 looks like utter crap...

Does anyone know if I can run the game in a window? If so, how?

Have you tried resolutions more suitable for you?
I'm running it in somewhat weird resolution (actually 1152*864, but you can try whatever resolution is supported by your setup.), but then again... I don't have huge monitor. :P

Edit your RA.INI (while game is not running) and put desired resolution there - See highlighted part:
[Video]
ScreenWidth=1152
ScreenHeight=864

StretchMovies=no

Changing resolution settings in game will affect this, so editing .INI directly is only way to make game using resolutions not already available in game settings.

I don't know if any direct way to run it in window even exist, but if you have enough horsepower to waste and nothing else works, you can run it in a sort of window... of virtual PC. :rolleyes:

#5 Cooler

Cooler

    Member

  • Members
  • PipPip
  • 181 posts
  • Gender:Male

Posted 15 August 2006 - 06:41 AM

Your doing better than me, I can't get it to run period. Ever since I upgraded to this rig. Did you do anything or just not have any problems with the game?

Not working at all? Not even in compatibility mode? Weird.
Happens to me too, if I try to run it while in dual monitor mode, but I can live witt it.

#6 Tylosis

Tylosis

    Member

  • Members
  • PipPip
  • 58 posts

Posted 15 August 2006 - 11:31 PM

Have you tried resolutions more suitable for you?
I'm running it in somewhat weird resolution (actually 1152*864, but you can try whatever resolution is supported by your setup.), but then again... I don't have huge monitor. :P

Edit your RA.INI (while game is not running) and put desired resolution there - See highlighted part:
[Video]
ScreenWidth=1152
ScreenHeight=864

StretchMovies=no

Changing resolution settings in game will affect this, so editing .INI directly is only way to make game using resolutions not already available in game settings.

I don't know if any direct way to run it in window even exist, but if you have enough horsepower to waste and nothing else works, you can run it in a sort of window... of virtual PC. :rolleyes:



Well, thanks for that, didn't know about that .ini.

Running it in 1600 x 1200 is good enough now, now to try virtual PC. :)