Jump to content

Gentoo/grub Install Freeze


Recommended Posts

Ok... was trying to install Gentoo useing stage 1... I believe I followed the directions to the T, but for some reason I'm having trouble...


After I work my way through the install, set up grub, and everything else.. and then logoout and unmount the system... reboot, and the system goes through the POST... shows the system information, "Verifying DMI Pool Data.....", "Boot from ATAPI CD-ROM:", and then the spot where it freezes... "GRUB"


That's it, just says "GRUB".


System is set up as follows:

hda - Windows XP (3 parts... but who cares)


-- hdb1 (boot) Linux

-- hdb2 Linux Swap

-- hdb3 Linux


/boot/grub/grub.conf looks like this:


default 0 
timeout 30 

title=Gentoo Linux 
root (hd1,0) 
kernel (hd1,0)/boot/kernel-2.4.20-gentoo-r7 root=/dev/hdb3 
initrd (hd1,0)/boot/kernel-2.4.20-gentoo-r7 

title=Windows XP 
root (hd0,0) 




This is my 2nd try installing Gentoo... ran into the exact same problem the 1st time around... figured I had just left out something, or skipped a step... but this time around, I made sure I didn't skip anything. :/ Any idea what I messed up on the install? More importantly, how do I need to go about fixing this issue?


Probably also worth pointing out... I cant use a boot floppy... no floppy drive in any of my systems. :/

Edited by d3bruts1d

Share this post

Link to post
Share on other sites

Sheesh... Gentoo Linux is a pain in the butt to install from Stage 1. At least for me it is.


Finally got grub to work, and then had probelms getting gdm to work... figured the gdm out easily... and no I'm having trouble with gnome.


When I emerge -k gnome it will emerge all of the files except for two... and I think the only reason it wont emerge the 2nd one, is because the emerge stops with the next to last file with this error:


* you need mozilla-1.4+ compiled against gdk+-2 
* export USE="gdk2"; merge mozilla -p 

!!! Error www-net/epiphany-1.0 
!!! Funcition pkg_setup, line 42 exitcode 0 
!!! need mozilla compiled with gdk+-2!!


Now, seeing that it wanted Mozilla (god why... I don't want Mozilla), I installed it.... emerge -k mozilla. And then tried to emerge gnome again, and got the same error as above. :/


Then I found out I needed to USE="GDK2" emerge -k mozilla so I remeoved mozilla by emerge -c, and then issued the emerge command with the use gdk2... that finished after an hour or two, and I tried to emerge gnome again... and once again, I got the same message.


On a side note... the network wont work when I boot to the system. Try setting up the eth0 and route statements exactly as I did during setup, and all I end up with is a bunch of TX/RX errors and dropped packets. :/ Funny thing is, if I boot with CD1 and issue the commands, I get network activity.


Oh well. I'm tired of messing with it. While I've learned a lot, it's been a week trying to get Gentoo installed. RedHat only takes an hour at most... sheesh. Probably would have enjoyed Gentoo, but I've got work I need to do, and have to have the Linux system available to do it... The slack 9.1 CDs are downloading right now via BitTorrent, and should be finished by the time I get home from work... time to give Slack a try. From what I've heard, the Slack install is pretty simple and straight forward.

Share this post

Link to post
Share on other sites

I'm afraid to try debian, just because their web site looks like crap. I mean... if they can't build a decent web page, why should I think they could build a decent OS?


I know... it's not fair to debian. But I do judge a book by it's cover.

Share this post

Link to post
Share on other sites

well I dono if that assumption really applies to the linux community...

I mean look at slackwares site... it's very basic and I dont think

it's really changed in years... cause it's not like they really make

any money off their distro's especially on the web.

but ya.... you know what Im getting at

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...