Jump to content

Is my SATA controller SATA II compatible?

Recommended Posts

Yesterday I bought a Maxtor SATA 2 3.0 Gbps NCQ hard drive. The model is 6V200E0.

It is recognized by BIOS, but when I start my PC with it (regardless if it is on any of the four sata connectors) everything freezes right after "backing up bios.... OK" with the HDD LED constantly ON!


I tried everything, Partition Magic recognizes the drive, I made a copy of my old drive over the new one, but it refuses to boot.


Then I noticed a small jumper on the HDD which stated SATA 1.5 Gbps Limit. I moved it and voila. Everything is working OK now.


So what is the problem with my onboard SATA? Is it SATA 2 as my HDD or not?

Share this post

Link to post
Share on other sites

The NForce4 SATA controller on the Ultra-D is SATA II compatible, but it looks like you've run into the Maxtor/NVidia incompatibility issue that has been reported before. Search the threads for Maxtor and you'll see what I mean.


Some people have had no trouble with Maxtors, others have had to get a firmware upgrade from Maxtor. I eventually gave up & bought a cheap SATA controller card & plugged the Maxtors into that and they worked fine.





Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...