Jump to content


Photo
- - - - -

Corsair SPEC-ALPHA FRONT PANEL USB 3.1?


  • Please log in to reply
4 replies to this topic

#1 Dynamic

Dynamic

    Total Nerd

  • Members
  • PipPipPipPipPip
  • 3384 posts
  • Gender:Male

Posted 13 April 2017 - 09:00 PM

How do i go about replacing the front panel USB 3.0 to USB 3.1 after upgrading motherboards that no longer support USB 3.0? The female connector on my old motherboard that supports USB 3.0 had 20 pins. Does the USB 3.1 have 20 pins? Would a front panel usb 3.0 be compatible with a female i/o internal usb 3.1? Anyone?


i7-7700K | H100i V2 | ASUS Prime Z270-AR | Corsair LPX 2x4GB 8GB 3200MHz | ASUS ROG STRIX 1070 OC | Samsung 850 Evo 1TB | Corsair AX860 | Carbide SPEC-ALPHA | Dell 24" IPS U2414H | Razer ManO'War 7.1 HS | WINDOWS 10 RED STONE 3 64BIT


#2 Dynamic

Dynamic

    Total Nerd

  • Members
  • PipPipPipPipPip
  • 3384 posts
  • Gender:Male

Posted 15 April 2017 - 03:17 PM

I know these new motherboards have back panel i/o 3.1 usb, but does it still have the 3.0 front panel connector on the motherboard or 3.1? Has anyone upgraded their front panel case with usb 3.1 yet or there is no need too?


i7-7700K | H100i V2 | ASUS Prime Z270-AR | Corsair LPX 2x4GB 8GB 3200MHz | ASUS ROG STRIX 1070 OC | Samsung 850 Evo 1TB | Corsair AX860 | Carbide SPEC-ALPHA | Dell 24" IPS U2414H | Razer ManO'War 7.1 HS | WINDOWS 10 RED STONE 3 64BIT


#3 Dynamic

Dynamic

    Total Nerd

  • Members
  • PipPipPipPipPip
  • 3384 posts
  • Gender:Male

Posted 15 April 2017 - 03:23 PM

Nevermind the only usb 3.1 there is, is on the back i/o, only 3.0/2.0 for front panel.

 

 

 

1 x USB 3.0 connector(s) support(s) additional 2 USB 3.0 port(s) (19-pin)


i7-7700K | H100i V2 | ASUS Prime Z270-AR | Corsair LPX 2x4GB 8GB 3200MHz | ASUS ROG STRIX 1070 OC | Samsung 850 Evo 1TB | Corsair AX860 | Carbide SPEC-ALPHA | Dell 24" IPS U2414H | Razer ManO'War 7.1 HS | WINDOWS 10 RED STONE 3 64BIT


#4 Dynamic

Dynamic

    Total Nerd

  • Members
  • PipPipPipPipPip
  • 3384 posts
  • Gender:Male

Posted 12 January 2018 - 08:51 PM

You know it's been several months since the motherboard installation and none of my USB 3.0 flash disks or external hard drive work with the front panel on my case. One of my flash drives just turns on, but doesn't appear in Windows. The only usb flash drive i got working is USB 2.0. What a mystery...and i'm pretty sure i hooked it up all fine too.


i7-7700K | H100i V2 | ASUS Prime Z270-AR | Corsair LPX 2x4GB 8GB 3200MHz | ASUS ROG STRIX 1070 OC | Samsung 850 Evo 1TB | Corsair AX860 | Carbide SPEC-ALPHA | Dell 24" IPS U2414H | Razer ManO'War 7.1 HS | WINDOWS 10 RED STONE 3 64BIT


#5 Dynamic

Dynamic

    Total Nerd

  • Members
  • PipPipPipPipPip
  • 3384 posts
  • Gender:Male

Posted 13 January 2018 - 01:35 PM

Okay, so i was playing around with the front two USB 3.0 ports on my case last night with a USB 3.0 Flash drive and i finally got both ports to recognize the USB properly. Finally! I had to insert it two or three times for it to work. Now i have another machine in a different room that would work the first time you plug these things in, but i guess my case is alittle tricky compared to that system in the other room. But what a relieve after what now several months of thinking there is something wrong with the two front USB ports in my case. 


i7-7700K | H100i V2 | ASUS Prime Z270-AR | Corsair LPX 2x4GB 8GB 3200MHz | ASUS ROG STRIX 1070 OC | Samsung 850 Evo 1TB | Corsair AX860 | Carbide SPEC-ALPHA | Dell 24" IPS U2414H | Razer ManO'War 7.1 HS | WINDOWS 10 RED STONE 3 64BIT