Jump to content
Sign in to follow this  
jhbodle

Crucial Ballistix 2x1GB PC4000 kit gone bad (merged)

Recommended Posts

Both my PC3200 512mb sticks died in similar circumstances to the reports of the PC4000 1gb sticks. Memory degraded requiring me to increase voltage from 2.7V where it was working well to 2.8V and eventually needed to have looser timings and underclocked and eventually didn't work well at all. However, it's true that there are not many reports with the 512mb sticks and PC3200 RAM. Whether this is because they don't have the problem much or because not so many DFI users are using the RAM is anyone's guess.

 

Since you have 1gb sticks, this isn't really that applicable to you but since the issue was raised, thought I should address it

 

N.B. Remember that the 1gb Crucial sticks were very popular for a time because they were one of the earliest resonably priced 1gb sticks which overclocked well out there. However most people using 512mb sticks had far more options with Geil, OCZ and others with TCCD and similar RAM being generally the most popular choices. This suggests to me that it is easily possible that far more people have used Crucial 1gb sticks with the DFI boards then 512mb sticks. But who knows really?

Share this post


Link to post
Share on other sites

um... I took the time to spell out exactly what JUST happened with me and newegg in terms of refund options etc. Please take the time to read the posts and don't add more confusion where there doesn't need to be any.

 

Bottomline if your ballistix starts to go bad and you got it from newegg, call newegg. You may still be able to RMA it even if you bought it 6months+ ago. They actually told me I had up to a year.

 

I sent my ram in and they offered me $250 or OCZ platinum EB modules this was like last week (May 15th). I bought my ram 8 months ago Oct 2005...

 

Also not EVERYONE is having this issue, but most are. It is definitely a problem with the 1gigx2 ballistix kits. Crucial and newegg both pulled them after they were having so many problems and started offering refunds or alternative replacements.

Share this post


Link to post
Share on other sites
Crucial is still selling the 1GB Ballistix- 1GB Ballistix

 

Where? I only see the Ballistix Tracer 1gb modules (with the extra LEDs). I don't know if Newegg is still selling Ballistix Tracer 1gb modules, assuming they ever did but as far as I can tell, Crucial is no longer selling the Ballistix 1gb modules

Share this post


Link to post
Share on other sites

Has anyone who didn't purchase the product from Crucial been able to convince Crucial to pay for return shipping (for you to ship the defective product back to them). What about internationally?

Share this post


Link to post
Share on other sites
just got my 2gb set back from crucial RMA today.

 

CL1115Y.P8 (Z503's)

 

hopefully these will pan out to be good. so far just running them at stock speed with a little bump in timings. 250 3-3-3-8 (2.7v) just popped them in and haven't had time to run tests (prime etc.) with the hardware in my sig.

 

ok, i had to post again in this thread, unfortunately.....

 

my second set just shat on me. i just got off the phone with them and they DO have some in stock, and they're supposedly a new revision which hasn't had any issues/returns yet. we'll see. i'm sending these back today or tomorrow. i'm tempted to give the new revision a try. these ran great for almost 6 months, then all of sudden i got system crashes w/ media player & it wouldn't even attempt to run memtest.

 

on a side note; even though the 2gb ballistix kits aren't listed on crucial's site, they do have them. also, they have 2gb tracers kits, although they're not listed on the site either. the tech guy was willing to give me the part number for the 2gb tracers if i was interested (i wasn't)

Share this post


Link to post
Share on other sites

[rantometer=7]

 

It makes sense.. they are not selling their 2gb Ballistix kits to new users, but those already stuck with it, they got a supply to give us as replacement... but this time I'm gonna request a refund.

 

Man with all this trouble with the Ballistix, they should say something, admit they had a faulty production line. Im sorry to say I will never buy something from Crucial again. I know they make more money this way, just replacing the sticks that are bad with (hopefully) good ones instead of calling back all sticks and make a official statement.

 

One can wish them "good luck" with their DDR2 sticks. Never ever ever Crucial for me. Uh ah. Wouldn't recommend it to anyone.

 

Now my 2nd set is deteriorating... went all the way from 265.5Mhz (3.0-3-3-8 1T) 2.7v, to 265.5Mhz with 2.9v, then down to 250Mhz 2.9v, then 230MHz 2.9v, 200Mhz 2.9v, 144Mhz 2.9v... and now I need to lower speed again to be "stable".

 

Piece of junk

 

[rantometer=0]

Share this post


Link to post
Share on other sites

Well, so far my TD1's are doing pretty good. They don't seem to need a lot of voltage- going from 2.6 to 2.8v doesn't seem to make them any more stable. I haven't played with the timings at all, I set EVERYTHING to Auto and they run DDR560 3-3-7-3 1T. I don't know much about setting memory timings, but I intend to learn. I have had these sticks @ DDR600, but they weren't stable, probably because I didn't have the timings set correctly. On the previous page of this thread someone posted some timings that he said are stable @ DDR600, I think I'll try those to see what happens.

 

I, too, would probably not buy the Ballistix again for reasons that have been mentioned. Most notably is that I (we) should not have to pay return shipping on a known faulty product. They also should do cross-shipping so their customer's rigs are down for as little time as possible. Micron is a multi-billion dollar corporation with multi-billion dollar Fabs all over the world. They should NOT be nickle-and-diming the people who made them rich- especially whn the fault is 100% Micron's for releasing a substandard product.

Share this post


Link to post
Share on other sites

Give the setting I posted on previous page a try. Try DDR600 settings with 2.6v - strength 7/3. Having played with them I have found that the Z503.16TD's I got from overclockers will run from DDR400 upto DDR600 with only 2.6 volts. very flexible with good timmings.

Having read the misery stories I am just going to keep my fingers crossed and hope they don't deteriorate with 2.6v cos I like them a lot!

Still -if they do I get to try some different sticks when I RMA them!

Share this post


Link to post
Share on other sites

well i guess they are running out of the straight ballistix,just rma'd mine and they sent me tracer.

same part with leds i believe,but my expert doesnt seem to like them.

mind you it doesnt seem to like any ram i have a t the mo.

Share this post


Link to post
Share on other sites

Well, I thought mine were dying, but it turned out to be the CPU. When that finally died (x2 3800 at stock), I had the Ballistix at 200MHz 2-2-2-5 1T. Ran 250MHz 3-3-3-7 1T as well with the 250 multi. The CPU mem controller was fine, just something else on the die blew.

 

Also, the one time they gave me real grief, I pulled them and cleaned all the dust out off the board, they were champion after that.

Share this post


Link to post
Share on other sites
well i guess they are running out of the straight ballistix,just rma'd mine and they sent me tracer.

same part with leds i believe,but my expert doesnt seem to like them.

mind you it doesnt seem to like any ram i have a t the mo.

good deal for you.

 

i haven't heard anyone with the same problems coming from the tracers. i'm still waiting for my new set from crucial. i had to call them today to see what's up. after giving them my tracking number showing that it arrived almost 2 weeks ago, they said they'd send them right out. i don't know what was taking so long, maybe i'll get some tracers (LED's) as well. all the feedback on the tracers have been great. if i have to RMA mine again, i will ask for an upgrade for sure.

Share this post


Link to post
Share on other sites

My second set died over a month ago and they recieved them on the 16th of last month. Got an e-mail on June 1st saying they were out of stock and it would be 7-10 days until they could ship. Now it's the 13th and there's still no word on the ETA for shipping.

 

I chatted with the online tech support to see if I could get a refund (got them last August, spent almost two months total waiting for replacements for both times) and they refused. All they would offer me is store credit. Still no ETA on the parts after I asked them specifically. I was hoping to just dump this memory and get some OCZ from Newegg. I may just take the store credit and run. All I want is some PC4000 that works. The only reason why I got the memory from Crucial directly is because hardly anyone had 2 GB PC4000 sets last summer and Neweg was out of stock.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...