Jump to content
Sign in to follow this  
jhbodle

Crucial Ballistix 2x1GB PC4000 kit gone bad (merged)

Recommended Posts

e-mailed crucial in scotland to ask is there a problem with the batch or is there a problem with architecture with there being so many problems, reply was that they were unaware there was a problem with the ballistix 2 gb kit.

I telephoned Crucial and spoke to somebody to ask the same question, she also said there was not a problem and told me because it was high performance ram it was difficult to set up and the people having problems just did not know what they were doing! She then suggested that with this ram being difficult to set up i should perhaps consider Crucials other range, I was not at all happy with that reply so I e-mailed the european general manager to complain, I pointed her to this link and pointed out that the people with the complaints certainly do know what they are doing, she apologized, said she would retrain the person at crucial in scotland and said an expert would be in touch with me. the "expert" telephoned me to say they had followed this link and had been in touch with Crucial in America who had also then been in touch with DFI to find out if it is only a problem with DFI boards, he said he would get back to me at ther end of the week to advice weather or not there was a problem with the DFI boards and I assume weather there was a problem with the ram.

Share this post


Link to post
Share on other sites

mrtell , to that post...

 

Two weeks ago a female at crucial said they where aware of problems with the ballastix

memory and was currently going through research to find out why, the phone call today

was different they where unaware of any problems at all and the low stock was just

rushing to buy the ram..

 

Withholding info?

Lieing?

Retail Bs?

 

who knows

Share this post


Link to post
Share on other sites

Second set just died. Ran at 280mhz but with only 2.7v and max Ive ever took them was 2.8v. Ran 2x80mm fans over them their WHOLE life, even when the computer was off as the fans were on a external PSU.

 

Junk sticks. Errors out the butt. This is bull crap. Lasted 2 months.

 

I havent had a chance to read the last 30 pages of this, but I assume the issue is still occuring even in the newer batches?

 

Sticks are batch CL1115N.2N

Share this post


Link to post
Share on other sites
Guest ElAguila

I honestly think with crucial that one hand doesn't know what the other one is doing. I have given up and ordered some of the G.Skill extreme 2x1gb pc3200 2gbzx ram. Newegg has issued an rma number for this crucial kit. Once I get it, I am going to sell it without even opening it. This was my first dealing with crucial and will probably be my last. I hate to judge companies on first products like that but the higher a company charges for their product the more I expect from it. Good everyone.

Share this post


Link to post
Share on other sites

well mine wouldnt run in 3d games from the word go, so who knows. ran mem test and 'rime for 12 hours and not a problem. ran games/vidios and they couldn't cope. and thats at default.

 

emailed crucial abuot it and they said they recomanded replacing them with out questioning my testing. they must have had loads sen back to them. they didn't even ask me if it was my graphics card.

Share this post


Link to post
Share on other sites

Thus far these ram chips are better, although unstable at 280mhz they DID boot up

and stay in windows i just ended up with strange behaviours the old ram sticks didnt even

work at 250mhz!

 

So atm its running at 232mhz, 3 3 3 10

Share this post


Link to post
Share on other sites
mrtell , to that post...

 

Two weeks ago a female at crucial said they where aware of problems with the ballastix

memory and was currently going through research to find out why, the phone call today

was different they where unaware of any problems at all and the low stock was just

rushing to buy the ram..

 

Withholding info?

Lieing?

Retail Bs?

 

who knows

TheyTell me something / they tell you something different. Do they not realize we all talk togeather, Does one hand not know what the other hand is doing or are they trying to misslead us???

I will post a copy of my E-mail from crucial "if i recieve one"

Share this post


Link to post
Share on other sites

my second set wouldn't do 260 stable without effort, which i haven't given much effort yet....but they run stable at 250 1T 3-3-3-8 (2.7v) prime tested for about 6hrs. these are only 2 weeks old so i'm not saying they're a GOOD set yet. we'll see.

 

if i have to RMA these, i'm going to sell them without opening them just like the rest of you.

Share this post


Link to post
Share on other sites

Well i got tis today from royal mail

 

"We have received your item and expect to deliver it before the guaranteed time on 13/01/06."

 

So ill have mine tomorrow and will post the batch number, will run them in for 24 hours first at stock speed first before upping it to see what they do.

Share this post


Link to post
Share on other sites

Yes, theres loads of them. Just an unusual high amount of bad ones. And seem's to be an unusual amount that have problems with DFI motherboards. Aint heard any bad ones on MSI/Gigabyte. Some asus boards.

 

It is a gremlin in the works somewhere, It seems to be linked to MB that allow an high amount of control over the memory from what ive seen

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×