Jump to content

Linux drivers?


Recommended Posts

I thought I remembered seeing some Linux drivers on dfi.com's support page, but can't seem to find any now that I need them.

 

I installed RH8 on a dual boot machine. The problem is that I can't enable my ETH port without drivers. Same is true for my sound. Am I not following the right steps to configuring a new installation of linux? Are the drivers on the same CD that came with the LP UT 250Gb nF3 containing Windows drivers? I'm not sure what the next step is.

 

Jay

Share this post


Link to post
Share on other sites

i know on my cd i got from dfi for my ut250gb that the linux drivers are on there, and yes u need to recompile the x86_64 kernel , well atleast i had on SuSe 9.2 x86_64. if u cant find the drivers on the cd check out nvidia.com they are on there

Share this post


Link to post
Share on other sites

Okay, I found the drivers on the CD and ran the .run script. A couple questions though...

 

Are the 64-bit drivers only for a 64-bit linux installation or is it also meant for a 32-bit OS on a 64-bit CPU? I'm thinking the former is correct, but the documentation didn't specify.

 

Also, help a linux newbie out... I'm used to installing from the CD and having the eth0 and sound devices configured for me automatically. When I install drivers I still need to configure Linux to activate both devices. What steps do I need to take to get sound and my LAN working?

 

I tried using 'insmod' to get my ethernet port working, but is this a permanent solution or do I need to add a symbolic link to something in my init.d directories? I can see my local gateway, but don't have access to a DNS server, which is odd. How would I enable the sound once I install the drivers?

 

Thanks to anyone who can answer my myriad of unorganized questions.

Share this post


Link to post
Share on other sites

Guest culinist

I just got done messing with these drivers, I know I found a great tutorial but can't seem to locate it now:( I believe you need to edit /etc/modprobe.conf to load the eth drivers. I will try to hunt down the link for ya if possible. As for sound I had no luck getting them running on my 250GB. Ijust use the drivers that shipped with yoper.

Share this post


Link to post
Share on other sites

Guest culinist

For the eth driver in /etc/modprobe.conf you need to add "alias eth0 nvnet". That worked for me. I still cannot get the sound drivers to work:(

Share this post


Link to post
Share on other sites

Guest culinist

ok sorry for the multiple posts but I got sound working by enabling Threaded Open Sound System in Multimedia and Sound in KDE. So now all is working with nvdrivers.

Share this post


Link to post
Share on other sites

Thanks for all your help!

 

Apparently I wasn't doing anything wrong with the nvnet module. I had installed it correctly and it was working fine. The problem was that it didn't automatically select the gateway router as the DNS. I manually set it to the gateway address and it started recognizing web aliases.

 

The sound is a little more complicated. I verified that the 'alias sound-slot-0 nvsound' line was already in my /etc/modules.conf file (apparently automatically added when I installed the drivers?). I can launch 'nvmixer' just fine and suprisingly, I can play a test sound successfully from 'System Settings'/'Soundcard Detection' window under GNOME. I still cannot play a CD though using xmms or the standard CD Player. I even set the Output plugin to the "OSS Driver 1.2.7 [libOSS.so]" without avail.

 

Do I need to configure the OSS Driver to point to a non-default Audio Device? Where would I enable 'Threaded Open Sound System' in KDE/GNOME?

 

Thanks!

 

Jason

Share this post


Link to post
Share on other sites

Guest culinist

In KDE you can find it in KDE Control Center > Sound and Multimedia > Sound System > Hardware > Select Audio Device > TOSS.

 

I put sound-slot-0 and sound-card-0 in /etc/modprobe.conf.

 

Any luck gettin that 9700pro configured yet?

Share this post


Link to post
Share on other sites

  • 2 months later...

The Radeon will be automatically configured by the Installed, but you won't get any 3D Acceleration out of it.

 

For you to have 3D Acceleration you'll have to install ATI's Linux Drivers which should be available on your graphics card website. If not, try the ones under the ATI Website, and be sure to send an email into your graphics card manufacturer asking them to support Linux.

 

Hope you get your problems fixed.

:cat: meow

 

Xeon

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...