Jump to content
Sign in to follow this  
ketchup_gsr

manual shutdown?

Recommended Posts

hi all,

 

i just reinstalled windows on my dfi infinity board and for some reason, i have to manually shut down the computer after i shut it down from windows. Is there a setting the i changed and didn't know about? Thanks

Share this post


Link to post
Share on other sites

sounds like you had ACPI (or is it APCI?) disabled in the BIOS when you installed, you can try changing in device manager your computer type to Advanced Configuration and Power Interface PC and see if that helps, but that may make you need to re-install as well. Make sure you ahve your ACPI enabled in the BIOS before you do a windows load.

Share this post


Link to post
Share on other sites

I had ACPI and APIC disabled when i installed windows on purpose, I heard it gives better 3D performance and has worked fine for me.

Share this post


Link to post
Share on other sites

it does to a limited extent, if you want them disabled, disable them after you install windows (although that can potentially cause problems) otherwise you will be stuck with a manual shutdown. Personally I haven't seen it maked enough of a difference to leave them off, it hasn't even been noticeable the times I have tried them.

 

edit:

and having ACPI disabled while installing windows is the only thing that I am aware of that causes you to have to manually shutdown.

Share this post


Link to post
Share on other sites

Also it is BIOS dependent. No ACPI/APIC (Standard PC) will not cause the incomplete shudown with BIOSes up to and including 1/31. Not sure about 2/15.

With 4/29 I had to reinstall Windows with ACPI enabled in the BIOS to get the complete shutdown. AFAIK APIC is not a factor.

Share this post


Link to post
Share on other sites

Advanced Configuration and Power Interface (ACPI)

Advanced Programmable Interupt Controller (APIC)

 

ACPI Uniprocessor PC => APIC on

Advanced Configuration and Power Interface (ACPI) PC => APIC off

Standard PC => APIC and ACPI off

Share this post


Link to post
Share on other sites

well APIC is definitely enabled... so does anyone know what is wrong? I don't want to reinstall windows... mainly cause i have a couple of incomplete games... i don't want to start farcry all over again, nor do i want to start rise of nation's world campaign all over again.

Share this post


Link to post
Share on other sites

Hi did you ever sort this as I have same problem after updating bios. :(

 

Had it on another computer and sorted it withing 5 minutes by changing a setting in device manager, but no joy on my Infinity ?

Share this post


Link to post
Share on other sites

if he sorted it or not. I do know if you flash to a later bios sometimes the defaults are different and in all bios flashes since the year 1 of computers there can be problems and users used to be cautioned to never flash unless the bios being flashed addressed their problem specifically.

 

As G_W says above there is a difference in APIC and ACPI and how they relate to each other. If by chance the 'early' bios had defaulted to ACPI on and you loaded windows and then flashed bios and the defaults changed> you run into problems. Normally the only real way to fix it is to make sure that APIC and ACPI are both enabled and then load windows again. From that setup when windoors is reloaded you can then disable APIC and still have ACPI and the computer will shut down as expected. WinXP is not like Win2K in that WinXP does not know where to find the APIC HAL when it was never loaded with it turned on.

 

So bios flashing with windoors loaded one way on this board can make for a problem later as G_W experienced until I explained it to him and he turned the stuff on that was supposed to be on and loaded windows.

 

Sincerely, RGone...:confused: as usual.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...