Jump to content
dling

2 Options For Windows Xp In Boot Post

Recommended Posts

I'm not sure where to post this Q: . I was doing a clean install of windows and choose the wrong hdd, it went for a bit with the install before I realized that I had chosen the wrong drive. So I restarted and choose the one I wanted the first time.

Did the complete install all is fine except when the computer boots up I got two options of XP to choose from one is the first , and the other is the full. I tried formatting the Hdd with the partial install as well as removing the drive all together . I cant seem to get the first one out and have it just boot , with no XP options. Even tried a saved bios that was different, no good. Any suggestions ?

Thanks.

Share this post


Link to post
Share on other sites

you need to edit the boot.ini file to have one entry...

 

the best way to do it is to rename one of the entries first so you know for definite which is which, then delete the line of the menu option for the OS that doesn't actually exist

 

boot.ini is in the root of C (assuming system drive is C) and is a system file, so you have to change folder options to unhide system files in order to edit it...

 

OR (this is the fast way of doing it)

 

do this:

 

Start > Run > notepad c:\boot.ini

 

this is what mine looks like, and probably what yours should look like:

 

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

 

the timeout value is ignored when there is only one menu option

Share this post


Link to post
Share on other sites

Well, the easy way to do it is to format the partial drive thru windows disk management and then do a fresh install on the hard drive you want it on. Always go into bios to make sure you have the right one up first. Or you can just unplug the one you do not want anything on it and then put plug back in after you install. To fix it the way is now can be done, but your going to wish you just did a fresh install. I sure you know you will have change something in the master boot.

Share this post


Link to post
Share on other sites

Sorry for hijacking this thread, but I have too options on boot up too. I don't know exactly how I ended up with two, except that it appeared after I entered Windows safe mode. My drive is not partitioned. How can I edit this so it just boots directly to windows?

 

This is what I have:

[boot loader]

timeout=30

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition (bootscreen)" /noexecute=optin /fastdetect /KERNEL=kernel1.exe

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect

Share this post


Link to post
Share on other sites

Delete this line:

 

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition (bootscreen)" /noexecute=optin /fastdetect /KERNEL=kernel1.exe

 

End result should be this:

 

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...