Jump to content
Sign in to follow this  
firky

X-Fi Snapping, Crackling, Popping (maybe there sponers of coco pops)

Recommended Posts

I found this Thread on the X-fi's

 

 

I've been having problems with my x-fi so ive been tryin to find out how to fix it....

 

 

 

In games:

If audio clipping only happens in certain games, and not others, it's possible that the game is trying to load more audio samples than the audio processor can handle (especially possible if the game automatically detects audio hardware). Be sure you have the X-Fi processor set to "Game Mode" in the audio console, first. Also, check to make sure that your playback resolutions are set at 44.1kHz. If playback rates are already set at 44kHz, and if the game has an audio option menu, try adjusting the number of audio channels if possible. If this isn't possible, you might need to do some research on the game and determine if there are any command line audio options or not. If the game employs a "command console" where you can directly change the games behaviour (i.e. Doom3, Quake4), console commands might exist that would allow you change the games audio setup.

 

 

after reading this i set me sound in COD 4 to 22khz and sure enough the about 99% of the clicking went away but it sounds crap comparted to the 44khz setting ...... so whats the piont of having a sound card if you still cant run the sound @ full settings......

 

 

 

 

next step

 

 

Hardware Acceleration disabled

Disabling Hardware acceleration can also cause audio clipping in certain programs. Make sure your hardware drivers are up to date, and if you are encountering problems with a specific game, make sure the game is patched to the most current version. Also, ensure that you are running the most current version of DirectX and OpenAL. To the best of my knowledge, audio hardware acceleration is disabled in Windows Vista (could a Vista/X-Fi owner please verify this for me?). In Windows XP, verify that hardware acceleration is enabled by going to Start>Settings>Control Panel>Sounds and Audio Devices; under 'Speaker Settings,' click "Advanced," in the new window that pops up, click the 'Performance' tab, and make sure the hardware acceleration slider is all the way to the right. If for some reason, the slider keeps being set all the way back to the left, there may be a hardware conflict, see below. In some programs, full acceleration has been known to cause audio clipping also, you may need to move the slider to the left one notch, if that proves unsuccessful, try two. Very rarely will turning off audio acceleration cure an audio clipping concern. You may also need to attempt to lower the playback quality in the same 'Performance' tab, and verify that playback resolution is set to 44kHz within the X-Fi Audio Console.

 

So i did this i set the Hardware acceleration too Full and set COD 4 back to 44khz and it seems to work fine. so i tryed a diffrent game .... so i tryed the "crysis demo" and "Sid Meier's Railroads" and it Crackled like a ######!! the intro vid's cracked realy bad but after i got in to crysis its seemed to clam down.... same with railroads it clamed down but was still crackling now and then .... why does this happen??

 

 

 

I went in to device manager and made sure there was nothing on the same IRQ as the X-fi ....

 

irq.jpg

 

My X-fi is on 18 and nothing else is on 18 so its not that...

 

 

Adjusting the PCI slot clock speed:

Some motherboards automatically set the PCI slot clock speed based upon the CPU clock speeds. This can lead to problems with certain hardware not functioning properly. If your motherboard BIOS supports adjusting the PCI clock frequencies, you should first set the clock at the PCI native 33.3MHz. If the problem still persists, you can attempt to increase the PCI clock speed. Be careful to not raise the PCI clock speed to high, as you could potentially damage your hardware. Also of note, if your BIOS does support changing the PCI clock, but does not list a clock speed for each individual PCI slot, and changes to the clock speed in BIOS will affect all installed PCI hardware. Be careful.

 

I cant change (i dont think i can) the pic clock in my bios soo the next option is

 

Adjusting the PCI latency:

Some motherboards will automatically set the PCI slot latency timer for each piece of installed hardware. Raising the PCI latency timer for the X-Fi can resolve audio clipping issues. If your motherboard supports adjusting the PCI latency timing, try raising it in increments and re-checking to see if the problem goes away. Some motherboards support changing the latency of each individual slot, and others only offer an adjustment that affects all PCI slots. If you raise your latency timings too high, other PCI devices that require frequent access to the PCI BUS could potentially lose data and cause the system to become unstable. Be careful.

 

 

my mobo gives me this option but i dont no what option to change ...

 

bios.jpg

 

 

I enabled pci/vga palette snoop and this didnt help dont realy no wat it does either...

 

 

my next step is to change the latency but i realy dont have a clue what i do to ..... so if reading over this and you think ive missed soem thing that will stop my card from being a coco pop it would be appreciated muchly

 

 

Cheers Firky

Share this post


Link to post
Share on other sites

are you using an analogue or digital out? have you tried audio creation mode with/without bitmatched playback?

Share this post


Link to post
Share on other sites

I am just guessing but would it do any good to turn off in Cmos any devices that use an interrupt (IRQ) that you don't need like

printer ports and com ports, probably not, but could'nt hurt.

Share this post


Link to post
Share on other sites
are you using an analogue or digital out? have you tried audio creation mode with/without bitmatched playback?

 

 

analogue

 

i have tryed diffrent mode's but i have not changed the bit settings because i donno how

 

 

i turned some com ports of and stuff didnt make any diffrence

Share this post


Link to post
Share on other sites

That pertty much fixed it... but now i have to keep it in that mode all the time now tho? Cuz the sound isnt as good as it is set up in Game mode with bass added and randoms tuff tweaked

Share this post


Link to post
Share on other sites

You can still apply an EQ correction curve in Audio Creation mode

 

have you tried different BIOS releases including betas? I don't have crackle with ANY bios release, but some are supposed to solve issues for people who have X-Fi probs

Share this post


Link to post
Share on other sites

Rice Krispies... For heaven's sake... if you cant even figure out what kind of breakfast cereal you are eating, what business do you have troubleshooting a sound card?!?!?

 

 

 

 

Kidding, of course. My LIVE used to crackle until I re-seated it and re-checked all my connections. Then it was fine. Carry on.

Share this post


Link to post
Share on other sites

LoL i dont eat that thats why i dont no what there called........ its seems great with thses new setting's just dont get the power and the bass and thump that i do i game mode .... i guess its just a matter of tweaking

 

LoL i dont eat that thats why i dont no what there called........ its seems great with thses new setting's just dont get the power and the bass and thump that i do i game mode .... i guess its just a matter of tweaking

Share this post


Link to post
Share on other sites
Coco Pops are called Cocoa Krispies in the States... :P

hi

I had the same problem -I have the same mobo with a x-fi plat. card-what I did wuz turn donwn all he mic feeds and presto problem solved -mine wuz the line in/mic 2-it's worth a try ---good luck

Share this post


Link to post
Share on other sites

Turning on all / some of the "effects" / sound processing, including going nuts with the EQ, does nasty things with the X-fi. I've not investigated further than seeing it happen on the scope, but there appears to be only a certain amount of 'headroom' (certain amount == not much at all) before stuff starts getting clipped. If you're doing large EQ boosts, I recommend you turn the master EQ level down. For example, if you were to apply +10dB @ 30Hz, drop the master EQ level at least -10dB. The 'Crystalizer' also adds to the problem. If you must use that, drop the master volume level down a bit to compensate.

 

This does mean you have to turn the volume further on your amp, but it does avoid clipping at the source (x-fi in this case).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...