Jump to content
Sign in to follow this  
trodas

X-Fi sound bugs? I think I have a solution.

Recommended Posts

In spring 2006 I finally get my hands on X-Fi Fatal1ty card. The reason for upgrade from my Audigy2zs was mostly the pause bug, BF2 support (I started play BF2 a lot) and the X-ram thing, that provide 64MB soundbuffer that should dramaticaly reduce PCI load - hence give me some speed-up :D Or so I thought. The first nasty surprise when I actually get the card in my hand was this:

 

xfifatal1ty3xt6.jpg

 

Not only the unnecessary long legs, but mainly the capacitors type - Jamicons. Jamicon cap's are bad, they are known to fail - eg. over time lost most of their specs.

At first, everything work great, except some weird noises when BF2 is loading sounds. (maybe the card did not like OGM playback when there is going writing samples to the X-ram? Or my A9R480 Sapphire Grouper mobo is up to blame?) However after like 2 months are the pause bug back.

 

When I say pause bug, I mean this. Using any player, play a AC3 5.1 movie while using 5.1 speakers on analog connection. Decoding filter has to be AC3 filter and it has to use 24bit output to generate enough data to trigger the failure. Now randomly pause and unpause the playback. Sooner ot later the channels start play from wrong speakers and/or there is terrible noise from all speakers comming after the unpause. This is a pause bug. I had it on Audigy (1), Audigy2zs and after two months on X-Fi as well.

 

It was obvious that the X-Fi is need to be recapped and the Jamicons changed to good, preferably audio caps - but NOT for all positions. The catch is, that Creative did use one capacitor type for all positions - eg. for the voltage filtering as well, as for the audio output. That is nonsense at best. Audio and computers capacitors don't mix!

So, they simply put Jamicons everywhere. Not something that I would expect from 260$ pricetag (spring 2006, mind you) product :hitwall:

 

xfifatal1ty1tp4.jpg

 

xfifatal1ty2et0.jpg

 

Now why I started this thread.

 

Well, to begin with, some weeks ago (to 14. 8. 2006) I started to play Mafia - a original Czech game of the 1930 NewYork organized crime. You simply work your way up in the organization at prohibition times, drive old cars, steal, murder and finally seek salvation from the hands of cops... During play it sometimes in these briefing talking scenes is seems to starting to lost some samples. I thought that the Czech programmers engine simply could have some quirks with 64MB of sample buffer on X-Fi Fatal1ty. After all, as the game release there was not such a thing as X-Fi, right? However the more I play and the closer to the end I was, the more often it happening. And it kinda suxx to go on mission and not know the briefing, right? However as I finished the game, the problems are gone, so...

 

So then I started play Prey :) And when shortly in game in one spot appears more sounds at once (your girl scream, mechanic move, buttons, alien...), the whole computer freeze. I remember the Jamicons and quickly pull the X-Fi out and replaced the big Jamicon (originaly a 220uF 16V) with Panny FM 470uF 16V as well, as two 100uF Jamicons with 120uF Panny FM ones.

 

 

 

The results.

 

I finished whole Prey in few days of hard gaming w/o crash or any problem. I went back to Mafia and - whoa, samples aren't lost anymore again. My apology, Czech programmers. I did not trusted in yours skils... :redface: In adition, the pause bug is - GONE! :D

 

Pause bug - long story:

Pause bug

Long time ago I decided to upgrade my speakers. It was when Matrix Reloaded was released and I realized my own homemade apm + speakers are simply not enought. They can't handle the extremly low-frequency effects designed for subwoofers to "shake your world and body" combined with the music. The fight scene with many copy's of Agent Smith verzus Neo was shiny example of my speakers inequality - beside every friend visiting me was constantly asking where I bought them, because they play, well... very well :good:

So, to make some use of my SoundBlaster Live! 5.1 output I choosen a Genius SW-5.1 wooden speakers, because they sound damn good (with some modifications, better opamps, cables and stuff). Now the best AC3 decode was a AC3 filter. It sound damn good, however there also come the price. Every time I pause ANY movie using ANY player (Mplayer, Mplayer Classic, BSplay, SoubtitleWorkshop DS preview play, etc) and then quickly unpause it, it sometimes swap random channels. And believe me, hearing subwoofer efect from mid speaker and speaking of actors thru the subwoofer is not exactly exciting...

It was also (SB Live! 5.1) not capable of 24 bit output.

 

To fix this ughly pause bug and get 24bit, I go and bought Audigy soundcard. Later are revealed that the Audigy is not exactly 24bit at all and my ears kinda relalized it anyway. And futhermore, not only the quality of sound did not improve over SB Live! 5.1, but the pause bug become more frequent and it add a whole new trick. Most times the "channel swap" was not enought. Now it mostly push hi-volume noise into most or all channels...! Believe me, suddently hearing high volume noise from all the 6 channels will make you jump :angry:

 

To get true 24bit output AND get rid of the pause bug I bought later an Audigy 2 ZS card (after checking and realizing the simply Audigy 2 card witch friend has with same speakers, did not improve much of the sound), but the pause bug did not disappeared at all. That make me kinda furious and angry.

 

Yet about year and half back I invested again into Creative crap and bought a full-featured X-Fi Fatal1ty for enhancing my BF2 play experience and eventualy geting rid of the pause bug. That was likely the last time I bought anything from Creative. Not only I have to mod drivers to work/install on Win2k a bit, but they also suxx and the pausebug is still here.

I managed to get rid of it for some month or so, after I replace some major caps on the X-Fi, but as the other caps aging (and they are bad brand of caps also - something that is hard to believe in a $260 pricetag at the buy time product) I get the pause bug yet again.

 

So there you have proof, that Direct Show decoders seeking could be a problem, when using 5.1 output with 24bit AC3 filter settings and quickly do many random pause/unpause of a AC3/DTS movie.

 

It (the pause bug) travel with me on many different mainboards/CPUs and happen even in completelly new mobos - and even now, when I have mobo with all good caps and completely recapped PSU. I planing to get rid of it by complete X-Fi recapp + add enhanced and brutal PCI voltage filtering for the X-Fi + shielding the X-Fi.

 

 

Later.

 

So I added the frontpannel later (moth or so), but in like a week, problems and pausebug are there again. Frontpannel is full of Jamicons too, and it obviously accelerated the dying of Jamicons on card or so. I pulled it out, yet the pause bug is still there. No crashing, luckily.

 

 

I would like to hear from X-Fi and perhaps also Audigy2(zs) users about their experience and possibly about their sound bugs. There is so many people on Creative forum that claim to have similar issues as me, so... I wonder in how many cases this could be avoided just by using good caps and not Jamicon crap...

 

 

 

To completely recap X-Fi you need:

 

X-Fi Fata1ity

-------------

Remove and short 16x 22uF 16V Jamicon decoupling caps - C23, C50, C76, C77, C28, C55, C85, C83, C61, C32, C62, C26, C67, C36, C34 and C68. http://img120.imageshack.us/img120/165/xfi...ngcapsgoan9.jpg

 

1x Samxon GC 1000uF 6.3V (d8) Big Pope

2x Samxon GD 470uF 6.3V (d6.3) Big Pope

17x Panny FM 150uF 6.3V (d5) P12917-ND Digi-key

1x Panny FM 100uF 10V (d5) P12919-ND Digi-key

2x Panny FM 68uF 16V (d5) P12921-ND Digi-key

4x Panny FM 47uF 25V (d5) P12923-ND Digi-key

6x Black Gate N 4.7uF 50V (d5) - d6.3 can fit Sonic craft

2x Black Gate C 4.7uF 50V (d5) - d6.3 can fit Sonic craft

 

(you can ship the Black Gates and only remove the original caps off the card, if you are not plan to use the 10pin Creative connector and the AUX-IN connector near it)

 

 

Audigy 2zs

----------

3x 100uF 16V d6.3 (Jamicon) - P12922-ND

5x 47uf 16V d5 (Teapo) - P11196-ND

35x 22uF 16V d4 (Jamicon) - P11213-ND

5x 10uF 16V d4 (Jamicon) - P11212-ND

11x 4.7uF 50V d4 (Jamicon) - P10315-ND

3x 1uF 50V d4 (Wincap) - P10312-ND

 

(digi-key.com product numbers used)

Edited by trodas

Share this post


Link to post
Share on other sites

So that's the answer to my pause bug? :O

 

And I hate to tell you this, but audiophiles (such as myself and hardnrg) have been recapping and replacing the op-amps for a while now (couple months). :P

 

So, you're going to recap the entire thing? Awesome. As far as I know, for sound, only reccapping the "main" caps (or whatever) matters, and reccaping the rest of the board only matters for longevity.

 

http://forums.overclockersclub.com/index.php?showtopic=71127

http://www.head-fi.org/forums/showthread.php?t=229350

 

EDIT: Don't forget EMI shielding!

Edited by LivingGhost

Share this post


Link to post
Share on other sites

would it be possible that these bad caps could slow down a computer... because it seems that my computer has gotten a bit slower since I installed my x-Fi platinum about 18 months ago? I haven't really noticed any other problems except I get artifacts in FEAR and stuff but I think that's from my bad OC on my GPU

Share this post


Link to post
Share on other sites

This is a picture of X-Fi Fatal1ty by user Raggingbone that continue to have crashes and stuff with the card:

 

failingjamicononxfiragguc3.jpg

 

No wonder when the Jamicon for main X-Fi chip is alredy leaking!

 

osconsepcxfidk6.jpg

(X-Fi Fatal1ty Sanyo Os-con SEPC 820uF 2,5V for main chip voltage filtering used)

 

This attempt not helped me to get rid of the pause bug - eg. pausing and unpausing movie with any player, using AC3 filter 24bit output cause switched channels or terrible noise after unpause.

Damn.

Bridging the polymer with 10uF SMD ceramic helped a bit more, but it is still like 50/50 chance to get a pause bug there. Panny FM 470uF with 4,7uF ceramic helped me much more before, damn.

 

Next try - 1000uF Samxon GC bridged with 4.7uF CMD ceramic (Tayo Yuden).

 

Nah, next try - try to study how to voltage regulation for the main X-Fi chip is done in the first place :D

 

So, the volage regulation for the main X-Fi chip is made by TI PS54352 chip.

http://www.ti.com/lit/gpn/tps54352

The recommended use is this:

 

tips54352recommendedusaeu8.gif

 

From this is quite obvious, that Creative design is very bellow specs one and for example - the imput filtering elyte capacity should be at least 100uF and as close to the chip a 10uF (at least) ceramics low-ESR cap. The Creative imput filtering elyte are 22uF Jamicon (!) and I did not yet measure the ceramic one, but I fear it is not "at least" 10uF as it should be.

Measured 15uF. I should desolder it, I think I measure something else with it also...

 

Same for the output. I see bulk capacity there, a 330uF elyt, 100uF another low esr cap and 0,1uF ceramics. Creative used a 220uF Jamicon witch is not low ESR cap in any way, shape or form...

 

So now it is clear, why I get the best results with mediocre 470uF Panny FM 16V cap (mediocre because using 16V cap on 1.25V a "bit" soften it's specs) with bridged 4,7uF ceramics are best and why the ultra-low-ESR polymer was not a great there.

 

My fault. Now I also going to replace the imput filtering "bulk" capacity - by Creative 22uF 16V Jamicon - by me a 150uF 6.3V Nichicon HE :dev: Yet the usage of 470uF Panny FM bridged with 0,1uF ceramic cap is not so great also. I still having the "pause bug"...

 

 

Considering what might cause the "pause bug" I do wonder, how well Creative followed up the DAC recommended connections:

http://www.cirrus.com/en/pubs/proDatasheet/CS4382_F1.pdf

 

xfifatal1tydackj6.gif

 

xfifatal1tydaccircuiteu6.gif

 

 

 

 

PS. I just replaced the there output opamps from the old useless (they was used even in Audigy (1) !!!) MC4558C ( http://www.alldatasheet.com/datasheet-pdf/...S/MC4558CD.html ) to the praised LM4562 ( http://www.alldatasheet.com/datasheet-pdf/...NSC/LM4562.html ) opamps. It was kinda easy, however the changes are minimal. You cannot hear any difference in mp3 bellow 320kBi, that is for sure. When we talking about DTS 768kBi, well, ten there finally is some difference :D But not so major. It is obvious that complete recap of the Jamicon crap caps has to be done as well, as the audiojacks has to be gold-plated for the subwoofer connection, the whole subwoofer has to be recapped and possibly modified also, so there is a notable difference.

 

Ask the Nartional Semiconductor for there sample pieces of the LM4562MA in the SOIC NARROW version for free there:

http://www.national.com/pf/LM/LM4562.html

And you can replace the there 4558 "things" used for the output channels :dev: There is also another opamps for mic in, line in and some more down there... So maybe a 6 opamps is not a bad idea.

 

 

PS2. parts list for SB0460 - X-FI Fatal1ty:

http://rapidshare.com/files/90009691/X-Fi_Fatal1ty_parts.txt

parts list for SB0550 - X-FI Elite Pro:

http://rapidshare.com/files/90009544/X-Fi_...e_Pro_parts.txt

...a good start :)

 

A few interesting (but not mine, Bichi's work) X-Fi mod pictures:

xfimod004ble9.th.jpg xfimod013bfz0.th.jpg xfimod022bwl1.th.jpg xfimod029bok1.th.jpg xfimod033cru6.th.jpg xfimod034bgp2.th.jpg xfimod042byb1.th.jpg xfimod043bgb4.th.jpg xfimod055biw9.th.jpg xfimod058boa0.th.jpg xfimod063bys3.th.jpg xfimod064bej0.th.jpg xfimod070bjj8.th.jpg xfimod080bil4.th.jpg xfimod083bhs8.th.jpg xfimod084buf0.th.jpg xfimod086brz6.th.jpg

Share this post


Link to post
Share on other sites

Middle stage of my experiments - Panny FC 22uF 25V used, before simple wires are used:

 

xfiwithpanasonicfccapsad6.jpg

 

Panny FC 22uF 25V instad of Jamicons 22uF 16V - not bad :xd: Finally the Opamps exchange produce hearing difference. W/O caps exchange = no difference! But only wires are better - give better audio details :dev:

(and noticably stronger bass line, witch is somewhat extreme sometimes...)

 

 

 

 

 

So, my mods on X-Fi so far are:

 

Main chip

C177 - 220uF 16V Jamicon, main chip voltage (1.2V) filtering:

470uF 16V Panny FM d8 - good, but still pause big

3300uF 10V Samxon RS d10 - card did not work at all (!!!)

1000uF 6.3V Samxon GC - good, pause bug reduced

C172 - 22uF 16V Jamicon, main chip regultor voltage imput (5V) filtering -> 150uF 6.3V Nichicon HE

 

DAC - Cirrus Logic CS4382 - http://www.cirrus.com/en/pubs/proDatasheet/CS4382_F1.pdf

C16 - 100uF 16V Jamicon, DAC voltage (3.3V) filtering -> 470uF 6.3V Samxon GD d6.3

C107 - 47uF 16V Jamicon, DAC voltage (3.3V) filtering -> 47uF 25V Panny FM d5

C91 - 10uF 16V Jamicon, DAC voltage (5?V) filtering -> 150uF 6.3V Nichicon HE d5

C119 - 10uF 16V Jamicon, DAC voltage (5?V) filtering -> 150uF 6.3V Nichicon HE d5

 

Opamps

C46 - 100uF 16V Jamicon, opamps voltage (5V) filtering -> 470uF 6.3V Samxon GD d6.3

 

Unknown - at back of the card

Cxx - 47uF 16V Jamicon -> 47uF 25V Panny FM d5

C186 - 47uF 16V Jamicon -> 47uF 25V Panny FM d5

C205 - 22uF 16V Jamicon -> 22uF 25V Panny FC d5

 

 

New opamps LM4562 (old are NJM4556)

http://www.national.com/pf/LM/LM4562.html

 

Voltage regulator 1.2V (CA20K1 - main chip) - PS54352

http://www.ti.com/lit/gpn/tps54352

input (5V) cap filter - C172, output cap filter - C177

 

Voltage regulator 3.3V (???) - AMS1117

http://www.ortodoxism.ro/datasheets/Advanc...ems/mXuxzrt.pdf

 

Voltage regulator 5V (opamps + DAC VA) - UA78M05C

http://www.ortodoxism.ro/datasheets2/3/062...jp82zof95wy.pdf

input (12V) cap filter -

 

 

all the 22uF 16V Jamicons shorted as recommended:

xfiopampscouplingcapsgoan9.jpg

 

Too radical? As intermediate step you can try replace these Jamicons with Panny FC 22uF 25V caps - and hear the difference. In fact, there is almost no difference after opamps exchange, but huge after caps exchange WITH already exchanged opamps...!

 

 

So far I did:

Exchanged 4 opamps to the LM4562 ones

Removed 16 pcs of coupling caps C23, C50, C76, C77, C28, C55, C85, C83, C61, C32, C62, C26, C67, C36, C34 and C68 and shorted them all with wire to get rid of the cursed Jamicons and improve the quality of sound output

Replaced C177 to Samxon GC 1000uF 6.3V

Replaced C172 to Nichicon HE 150uF 6.3V

Replaced C16 to Samxon GD 470uF 6.3V

Replaced C46 to Samxon GD 470uF 6.3V

Replaced C91 to Nichicon HE 150uF 6.3V

Replaced C119 to Nichicon HE 150uF 6.3V

Replaced C107 to Panasonic FM 47uF 25V

Replaced C186 to Panasonic FM 47uF 25V

Replaced Cxxx to Panasonic FM 47uF 25V

 

xfiopampscouplingcapsrewb0.th.jpg

 

Interesting X-Fi Elite Pro mods:

xfielitepromod1fh9.th.jpg xfielitepromod2eo6.th.jpg

 

X-Fi Fatal1ty 12V opamps mod:

xfifatal1ty12vopampsmodjo1.th.jpg xfifatal1ty12vopampsmodfi9.th.jpg

 

 

Most important picture ever - X-Fi and voltages

 

Hard work, but there we go:

 

xficapsvoltagesgl3.th.jpg

 

In picture it looks this way - green are caps that has audio on them with stereo output, WinAMP playing...

 

C177 (1.23V)	 - 220uF 16V Jamicon -> 1000uF 6.3V Samxon GC
C16 (0.7V)	   - 100uF 16V Jamicon -> 470uF 6.3V Samxon GD
C46 (5V)		 - 100uF 16V Jamicon -> 470uF 6.3V Samxon GD
C107 (4.7V)	  - 47uF 16V Jamicon -> 150uF 6.3V Panny FM
C186 (5V)		- 47uF 16V Jamicon -> 47uF 25V Panny FM
C205 (0V)		- 47uF 16V Jamicon -> 47uF 25V Panny FM
C20 (2.47V)	  - 22uF 16V Jamicon -> 150uF 6.3V Panny FM
C33 (3.3V)	   - 22uF 16V Jamicon -> 150uF 6.3V Panny FM
C56 (-5V)		- 22uF 16V Jamicon -> 150uF 6.3V Panny FM
C72 (-5V)		- 22uF 16V Jamicon -> 150uF 6.3V Panny FM
C74 (12V)		- 22uF 25V Jamicon -> 68uF 16V Panny FM
C75 (-12V)	   - 22uF 25V Jamicon -> 68uF 16V Panny FM
C101 (5V)		- 22uF 16V Jamicon -> 150uF 6.3V Panny FM
C114 (5V)		- 22uF 16V Jamicon -> 150uF 6.3V Panny FM
C124 (3.3V)	  - 22uF 16V Jamicon -> 150uF 6.3V Panny FM
C172 (5V)		- 22uF 16V Jamicon -> 150uF 6.3V Panny FM
C206 (0V)		- 22uF 16V Jamicon -> 47uF 25V Panny FM
C209 (0V)		- 22uF 25V Jamicon -> 47uF 25V Panny FM
C27 (5V)		 - 10uF 16V Jamicon -> 150uF 6.3V Panny FM
C43 (8.8V)	   - 10uF 16V Jamicon -> 100uF 10V Panny FM
C91 (5V)		 - 10uF 16V Jamicon -> 150uF 6.3V Panny FM
C108 (2.16V)	 - 10uF 16V Jamicon -> 150uF 6.3V Panny FM
C115 (2.4V)	  - 10uF 16V Jamicon -> 150uF 6.3V Panny FM
C119 (3.3V)	  - 10uF 16V Jamicon -> 150uF 6.3V Panny FM
C123 (2.3V)	  - 10uF 16V Jamicon -> 150uF 6.3V Panny FM
C136 (5V)		- 10uF 16V Jamicon -> 150uF 6.3V Panny FM
C151 (3.3V)	  - 10uF 16V Jamicon -> 150uF 6.3V Panny FM
C18 (2.4V aud)   - 4.7uF 16V Jamicon BIPOLAR -> Black Gate N 4.7uF 50V
C19 (0V aud)	 - 4.7uF 16V Jamicon BIPOLAR -> Black Gate N 4.7uF 50V
C21 (2.39 aud)   - 4.7uF 16V Jamicon BIPOLAR -> Black Gate N 4.7uF 50V
C22 (2.47)	   - 4.7uF 16V Jamicon BIPOLAR -> Black Gate N 4.7uF 50V
C48 (2.26V)	  - 4.7uF 16V Jamicon BIPOLAR -> Black Gate N 4.7uF 50V
C49 (2.26V)	  - 4.7uF 16V Jamicon BIPOLAR -> Black Gate N 4.7uF 50V
C102 (2.4V aud)  - 4.7uF 50V Jamicon -> Black Gate C 4.7uF 50V
C104 (2.4V aud)  - 4.7uF 50V Jamicon -> Black Gate C 4.7uF 50V

Remove and short 16x 22uF 16V Jamicon decoupling caps - C23, C50, C76, C77, C28, C55, C85, C83, C61, C32, C62, C26, C67, C36, C34 and C68. It is possible to remove all the marked with green audio caps C18, C19, C21, C22, C48, C49, C102 and C104 if you did not use the AUX IN analog 2 channel CD in and the 10 pins Creative connector, for witch the 6 pcs of the bipolar caps are used to separate the AC3 6 channels signal (5.1).

35 caps total
-------------
1x Samxon GC 1000uF 6.3V (d8)
2x Samxon GD 470uF 6.3V (d6.3)
1x Panny FM 100uF 10V (d5) P12919-ND
4x Panny FM 47uF 25V (d5) P12923-ND
2x Panny FM 68uF 16V (d5) P12921-ND
17x Panny FM 150uF 6.3V (d5) P12917-ND
6x Black Gate N 4.7uF 50V (d5) - d6.3 can fit
2x Black Gate C 4.7uF 50V (d5) - d6.3 can fit

Share this post


Link to post
Share on other sites

Interesting mods there trodas :)

 

I've not had problems with my Creative cards like crashing, pausing, etc, but I've done a few mods on my Audigy2ZS and X-Fi cards to improve sound quality. I found the LM4562 op-amp switch had the biggest audible difference, replacing the main power cap to the X-Fi mostly improved the bass clarity, and shorting the main output caps lifted the overall clarity.

 

Since doing the mods and working on an amplifier design, I've found that shorting the output caps (maybe because of the LM4562 opamps too) produces a significant DC offset in the output. This isn't a problem if you are connecting the card to a regular amplifier (as it will have DC blocking caps on its inputs), but if you connect headphones or direct-coupled amplifiers to the shorted-output soundcard, you will pass the DC offset to the headphones or amplifier which could damage the headphone/speaker drivers.

 

Similarly, shorting the input caps will feed a DC offset to the input opamps, resulting in distortion of the input signal.

 

I'd recommend using some form of capacitor here, maybe some high quality non-polar audio-grade electrolytics would be sufficient to not affect the audio signal by having enough capacitance in such a small package (superior type caps are likely to be massive in comparison). Maybe you can use some really low ESR caps here to approach the sound of wire links, while blocking DC...

Share this post


Link to post
Share on other sites

You are right.

 

X-Fi output DC offset measuring:

--------------------------------------

L: -190mV DC, 10mV AC

R: -174mV DC, 10.2mV AC

RL: -210.2mV DC, 10.1mV AC

RR: -204.7mV DC, 10mV AC

CENTER: -209.5mV DC, 10mV AC

SW: -231.9mV DC, 10.2mV AC

 

But the opamps in amplifier are typically run from +/-12V, so a 200mV of DC offset on the input, amplifier to like 2V after the opamps is not going to clip or distort my audio signal at all ;)

While any capacitor will.

I plan blocking DC offset just before the main amplifier and not a second sooner :)

 

Why not use tantalum caps

http://www.hindawi.com/GetPDF.aspx?doi=10..../08827510212341

Read conclusion about noise in tantalum cap

The most important sources of fluctuation consist in regenerative microbreaks, fluctuation of polarisation and mechanical strain. The frequency dependence of noise spectral density in mHz region gives information on slow irreversible processes of tantalum pentoxide crystal-isation and oxide reduction. The self-healing process can improve sample quality due to leak-age current and noise reduction. :redface:

 

Or there:

Low Noise Balanced Microphone Preamp

I also recommend against the use of tantalum capacitors, and regular readers will notice that I have not suggested them for any project (although there was one suggestion that you could use them if you wanted to). The only capacitor fault I have ever had to track down with an intermittent short circuit was a tantalum bead type - it was neither fun, nor easy to find :-(

 

 

So, using tantalum caps in X-Fi are bad idea, alrough they might look as good choice at first and I must admit, I was considered them at first as well, but then I looked more deeply and contacted experts and they all recommended against it.

 

 

Interesting discovery!

 

I had enought of waiting and I decided to test, if the d6.3 caps (remember, the original ones are just d4) will fit there. So I took my poor X-Fi (I wish I get my hand on some dead X-Fi for this testings, but...) and started soldering on it again, even when I did not have to caps in my hands yet, sadly.

 

So, I desoldered them all and cleaned the holes nicely, because I knew I will solder them right back, but first I need to test the d6.3 caps there...

 

xfibipolaraudiocaps3gr6.jpg

 

So far, so good. Then I get the caps - I picked up a 8 pcs of - luckily to still have a few of them here and there - 120uF 16V Panny FM caps that are d6.3 - tought they are not bipolar and not audio caps either, but I was not going to solder them there - I just wanted to made some progress and to make sure we can fit a d6.3 caps there... So I just stick them thru:

 

xfibipolaraudiocaps1mr1.jpg

 

And they fit! :wahaha: Hoooray!

 

Another pic:

 

xfibipolaraudiocaps2mo2.jpg

 

And then I make the most important discovery yet. I suspected that before, but I was not sure. These 6 bipolar caps are for the Creative 10-pin connector 6 in/out channels separation.

The two ones are not bipolar, but normal caps and they are for decoupling of the CD-in (AUX IN) input.

 

This might not sound so important to you yet, but... I asked myself "What if I did not even use these connectors?" "Do I really need the caps there at all, or for the BEST possible quality is better to get rid of them completely?"

 

I mean - there is one thing better that good audio cap in the passing of audio signal. And that is wire - or no cap in this case.

 

So out of a pure luck and based just on a intuition I tried the X-Fi w/o these caps and quess what - it played and playing well still! :dev: :wahaha:

 

This is an important solution and very cheap audio improvement only for people who not use either of these connectors!

 

Amazingly and not unsurprisingly, once the Jamicons are out of the audio loop now completely, the detail level in music increased hearably once again.

However there is a side issue to that improvement. Now I can hear some compression distortions even at 320kBi, witch is considered as very high bitrate! Also, any more importantly, many many and many my mp3 music files contain some slight errors in music, that are now also possible to hear well...

 

In short, you might want to consider doing these mods (I'm being very frank here) because you will hear more that you might wish to hear :redface:

 

 

PS. old but interesting article: Creative's Sound Blaster X-Fi audio processor http://techreport.com/articles.x/8884

Share this post


Link to post
Share on other sites

Final look - the thread should be renamed to "X-Fi holocaust", as I removed everything I did not use/like :D

 

Bad caps Jamicons are OFF my machine, HOOORAY! :D

 

The dynamic seems to be improved slightly, but that could be just in my head...

However replacing the suxxking Jami-crap working as DAC voltage stabilization and be connected on the FILT+ pin COULD change/improve the sound...

(bear in mind that my audio output AFTER the X-Fi is reasonably suxxking low-end one, and I did not have so good ears... so maybe someone else spot much more noticable difference - or dismis my claim of slight improvment there)

 

X-Fiwithpanasoniccaps1.jpg

 

X-Fiwithpanasoniccaps2.jpg

Voltage stabilizing for opamps is very important.

 

X-Fiwithpanasoniccaps3.jpg

Voltage filering for the main X-Fi chip :)

 

X-Fiwithpanasoniccaps4.jpg

Useless stuff is gone now.

 

X-Fiwithpanasoniccaps5.jpg

Better voltage stabilization for the Wolfenson audio codec can't hurt too :P

 

X-Fi holocaust :D

removed everything I did not use :D

 

 

PS. moders should rather consider rather AD8599 opamps, it has much better audio: http://www.analog.com/en/prod/0,,759_786_AD8599,00.html

 

PS2. another things to consider - get rid of the output muting transistors :ph34r:

Share this post


Link to post
Share on other sites
You are right.

 

X-Fi output DC offset measuring:

--------------------------------------

L: -190mV DC, 10mV AC

R: -174mV DC, 10.2mV AC

RL: -210.2mV DC, 10.1mV AC

RR: -204.7mV DC, 10mV AC

CENTER: -209.5mV DC, 10mV AC

SW: -231.9mV DC, 10.2mV AC

 

But the opamps in amplifier are typically run from +/-12V, so a 200mV of DC offset on the input, amplifier to like 2V after the opamps is not going to clip or distort my audio signal at all ;)

While any capacitor will.

I plan blocking DC offset just before the main amplifier and not a second sooner :)

as long as you have coupling at some point before amplification it's ok... those are massive offsets, a 2V offset is way off centre lol... also even a 200mV offset on the input will cause the signal to clip on the input side at like 70% of the possible signal, so you're effectively decreasing the signal/noise ratio of your system

 

offset is a form of distortion... you can hear the difference... sample some music in SoundForge, CoolEdit/Audition, and then artificially add a DC offset and play it back... it's weird, it's not the same as the original, therefore it is a form of distortion...

 

that said... my X-Fi is shorted on the output heh... and I rely on my amps' superior decoupling (loads of space in an amp for HUGE polycarbonate or polypropelene caps :))

 

I only really mention it because you brought up the amp question about removing caps in the signal path in another thread...

Share this post


Link to post
Share on other sites

Well, I rather thinking of modification on the X-Fi to get the offset under control.

It might sound crazy, but since the offset is 200mV to the negative... what about increasing the voltage from 5V to 5,2V? :D What would happen then?

 

As for the voltage increasing, well, that is easy. In X-Fi Fatal1ty is these opamps powered from 5V stabilized by the UA78M05C and it's output voltage can be increased very easily - just add a resistor between the common terminal and ground pin and the output voltage get higher ;)

(correct way is a voltage divider where you know the 7805 is trying to have a 5V voltage difference between output and the common terminal - so 200mV = 0.2V and that is 1/25 from the 5V... so a divider 1:25 (100R & 2400R resistors) will increase the output voltage by 0.2V to 5.2V :D )

 

What will happen then to the offset?

 

Another and better way is to use the AD8599 opamps with less offset and notably higher audio quality anyway.

 

And another thing to consider is the removal of the muting transistors on the X-Fi IN/OUTputs... These can add some more noise as well as the voltage...

 

that said... my X-Fi is shorted on the output heh...

 

How? I seen pics for 2 channels, but the rest?!

 

 

 

...and...

 

Big success! :D

 

I managed to quiet the R, L, RR and RL channels! :D At least for like 30% of the volume, witch is what I use daily. So, this is very good for me - if it was not that the center speaker brum is not gone ... (and subwoofer also product some noise, but at very low level, since the noise is like 5 - 6kHz and the subwoofer is optimized for much lower frequency anyway)

 

What I did over the original schematic?

 

Removed C117, C118, C119, C120, C121 and C122.

Replaced the C7, C8, C33, C34, C59, C60 and C63 with 12pF caps (original 100pF).

 

That almost instantly kill most of the noise from the R, L, RR and RL channels. Adding R100 resistors instead of C9, C10, C35, C36, C61, C62 and C64 seems to helped a bit too.

 

No hearable pot noise as others suggested that this is why these caps are there in the first place.

 

 

Current situation.

-----------------

The noisy center is VERY ANNOYING. However hear this - the the volume pot is at like 30% of volume, the R, L, RR and RL channels seems dead silent. But as soon, as I increase the volume, then the center channel noise quiet and all other channels become noisy...!!! :wired:

 

This is nuts.

 

It, however, I think clearly demonstrate one thing. That the oscilation is happening because of the output resistance.

 

I'm I right?

 

Also caps size on the opamp output seems to play a role, too. Notice that I complain about the noise in the center channel most. (because at 30% volume are the other channels dead silent, so... even later I wand them to be silent at ANY volume, right now I want get rid of the noise at all costs - except for unpludging the center speaker, that it is :) ) Then notice the C5 cap capacity. 0.22uF for center output from opamp?! Are you kidding me! I want there 22uF 25V Elna RFS cap and I think it will stop the noise - at least in the 30% volume settings.

Also notice the C116 cap - a 470pF one. It is NOT present in the recommended TDA 7360 schematic. I vote for removal... ;)

 

Input resistances

TDA 7269A - 20k (R, L, RR and RL)

TDA 7360 - 50k (CENTER)

TDA 7296 100k - (SUB)

 

So, do I get it right that these input resistances are maybe too high, and that cause the oscilations, because high input resistance mean high voltage and that cause high feedback and that, possibly, cause these oscilations?

 

I replaced almost all the audio decoupling caps with the Elna RFS 22uF 25V ones. All the input ones, and all four for the R, L and RR, RL channels. Can that be significant too?

Share this post


Link to post
Share on other sites

Removing X-Fi muting transistors.

 

Having transistors in the audio loop is definitively a big NO-NO, just go ask any audiophile of Hi-Fists and he did not even need to be an extreme one to tell you this. So, I concentrated my efforts this way. First I produced this picture of what is short direct contact on my X-Fi Fatal1ty: http://i232.photobucket.com/albums/ee193/t...mps_outputs.jpg

 

And todays I go deeper. It is same for each output. After opamp, there is a 33ohm resistor to protect the opamp from shortcut on the end. It has minimal impact on the signal, so, keep it. Later there are two muting transistors, for the positive and negative flow:

 

X-Fimutingtransistors.gif

 

And after them a two small caps to the ground to kill the possible high frequency interference. For L and R channels the card utilize 4 separate transistors. For the rest a dual transistor is used to save space - two (or coudl that be four?) ones in one.

 

Regardless, the removal is rather easy. First get rid of them:

 

X-Fiopampsholocaust.jpg

 

 

Then solder a shorts there:

 

X-Fimutingtransistorsremoval.jpg

 

X-Fimutingtransistorsremoval_2.jpg

 

...and you are free to test them. As you probably noticed, I for the work desolder the C46 and C27. And also as you sure noticed, I replaced the LM4562 opamps with AD8599 ones.

 

 

The results.

After hearing the sound, I was like "Holly ****...!"

There is no words to describe how much better it sounds. The oversharped thick sound of the LM4562 is gone (LM4562 also like to pick a lot RFI) and the sound is rich and full - and yet more detailed - very likely thanks to these muting transistors removed!

 

Fantastic change, damn I'm glad I did it! :)

 

 

Side-effects.

As everything in life, there is a price for this. Not only this is NOT easy mod (do NOT try that, unless you are soldering MASTER, and I'm not kidding) but it also has consequences. Not only you want to delete all, even the 320kBi mp3 files now, but upon the driver loading in windows boot, there is notable click in the speakers. Same when changing audio mode. Not louder that the amp is set for, so a minor price for such wonderfull, rich sound.

There is a bigger price and I was quick to discover it.

I remember it well from measuring the voltages on the caps on X-Fi. When I touch the opamps, well, then the X-Fi started to oscilate like MAD and the resulting sound noise, even on small testing speakers, are unbearable.

So, to get to it - I plug my rear speakers into the SUB/CENTER jack, so upon discovering that, I was like fixing this. So I unplug the jack... and the moment it started. The X-Fi, no longer protected with these muting transistors, start oscilating like mad. From all 6 speakers it output SO horrible noise and SO strong, that it was like when F18 is about to land on your head.

I can't remember anything comparable in my life.

My stepbro run to my room asking what the heck... so you get the picture.

The oscilating noise, when you change your speakers, does not stop till reboot.

 

For me it is fair price to pay. I just can't now hotplug the speakers of fiddle with them "on the fly", like I used to. This is kinda sad and limiting, but what one can do. I'm ceratainly not going to put these cursed transistors back, no way. I love the sound now way too much.

Share this post


Link to post
Share on other sites

My modification of X-Fi Fatal1ty, UK edition w/o heatsink on main chip and with caps wires bent to sides and then soldered from the bottom of the PCB for user Tez, Head-Fi forum:

 

X-FiUKeditionTez1.jpg

 

X-FiUKeditionTez2.jpg

 

X-FiUKeditionTez3.jpg

 

X-FiUKeditionTez4.jpg

 

X-FiUKeditionTez5.jpg

 

X-FiUKeditionTez6.jpg

 

X-FiUKeditionTez9.jpg

 

X-FiUKeditionTez8.jpg

 

X-FiUKeditionTez7.jpg

 

...and his card is working just great! B:)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×