Jump to content

Setting Up Samba Share Under Fedora Core 5


Nemo
 Share

Recommended Posts

I have installed Fedora Core 5 on my folding machines and have it up and running [email protected] with no problems. I would like to monitor this machine from my Windows XP box using EMIII so I decided to set up a Samba share on my Linux box so I could access the folding folder. The share shows up in my network places in Windows, but I am unable to access the share - I get an error dialog telling me that the share is not accessible and "You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions."

 

Here are the steps I took to get all this set up:

1) I created a Linux user and password identical to my Windows user/password

2) Folding is installed and running in the home folder of the Linux user

3) I set up Samba and made it a member of the same workgroup as my Windows box (which is why I can see the share on my Windows box).

4) I created a Samba user and password identical to my Windows user/password.

5) I made sure that the folder is shareable and even ran

chmod 777 -R /home/Nemo/foldingathome/*

to ensure everything was set correctly.

 

Here is a copy of my smb.conf file:

 

[global]

workgroup = FOLDING FARM

server string = Samaba Server on Farm2

netbios name = Farm2

hosts allow = 192.168.1. 127.

printcap name = /etc/printcap

load printers = yes

printing = cups

log file = /var/log/samba/%m.log

max log size = 50

encrypt passwords = yes

smb passwd file = /etc/samba/smbpasswd

dns proxy = no

username map = /etc/samba/smbusers

security = user

 

[homes]

comment = Home Directories

browseable = no

writeable = yes

valid users = %S

 

[[email protected]]

comment = [email protected] on Farm2

path = /home/Nemo/foldingathome/CPU1

writeable = yes

browseable = yes

 

So the end result is that it seems as if my configuration is OK becasue I see the share in Windows show up identified by the server string "Samaba Server on Farm2" and the share as "[email protected]".

 

So at this point I'm thinking I have a Windows issue. Has anyone successfully set up a Share on Linux that can help me out here?

 

 

EDIT: I found the problem! It was a Linux firewall issue. I went into the firewall and changed the setting for Samba from "Enforcing" to "Permissive" and everything works!

Edited by Nemo

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...