Jump to content
Sign in to follow this  
Ziggy54354

Harddrive Shown As Removable

Recommended Posts

This is more annoying than anything but my hd for some reason is being shown as removable. I dunno why it's happening. The hd and rig specs are the 2nd one in my sig. If i try to remove it it doesnt let me so i guess its not really gunna hurt my computer but its kinda bothering me. If anyone knows how to fix this please let me know.

Share this post


Link to post
Share on other sites

SATA drives support hot-swapping, kind of like USB drives. This is why Windows will show your drive as being removable.

 

However, since this is your primary drive, it either won't let you remove it or you'll experience some sort of crash/corruption if you try it. I suggest you just ignore it or set the taskbar to ignore the icon so that it doesn't show up.

Share this post


Link to post
Share on other sites

How do you tell it to hide the icon in the system tray?

Control Panel > Taskbar and Start Menu > check Hide inactive icons > Customize > then change its Behavior.

Share this post


Link to post
Share on other sites

EDIT: oops....next time i get caught up in work, i should refresh a page before replying. lol

 

you can just right-click on the taskbar and go to properties though...don't have to go thru the control panel.

Share this post


Link to post
Share on other sites

I get the same problem with my SATA drives too.

 

But it just hides the icon and all you have to do is click the arrow to expand it and its still there.

 

I still havn't found a way to get rid of the icon from the task bar compeletly.

Share this post


Link to post
Share on other sites

Found this on google.

 

For nForce chipsets, you can add the following to registry:

 

In HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ nvata,

 

add DWORD DisableRemovable, set to 1. Reboot.

 

64-bit systems use nvata64. Some chipsets might use nvatabus instead.

 

This doesn't work with VIA chipsets (driver vide or videX64), the only option I've found for them is to use older drivers that don't support SATA hotplug.

This worked perfectly, thanks buddy!

 

Worked great for me! :thumbs-up:

Share this post


Link to post
Share on other sites

Found this:

 

12. Do not dig up old threads! If you want to continue a discussion from an old thread (older than 2-3 months), create a new thread and reference the old one in your opening post if necessary. There is very little reason to dig up an old thread.

 

Works great for me :thumbs-up:

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×