Jump to content

Xandros Problem


Cathbard
 Share

Recommended Posts

I am having a problem configuring Xandros to talk to my ISDN modem. In Australia Telstra (the Gov't carrier that supplies all ISDN services) issues all ISDN customers with a modem made by Open systems called an NT1 plus2. This has been the standard device for over 10 yrs (well over).

Telstra ISDN

Open Systems NT1 plus2

They supply an install disk for Windows but not for Linux. They do however give the AT initialisation string which is:

AT Z !Z=9 !T0=0 !T2=10 !T4=1 E0 V1 &D2 &C1

Now !T2 is the threshold thats sets when the second B-channel kicks in. Data calls are capped in Australia so it is best to set it at 0 which forces it on and be done with it because it cost no more.

I set this initialisation in Knoppix using manual configuration and it worked fine (it did seem a little slow to load pages but that is another subject). However, I cannot seem to get any success using Xandros.

The NT1 can operate on either USB or RS232. I am using the RS232 port to simplify matters.

I run the connection Wizard in Xandros and select com1. The actual modem isn't selected so I looked for something close that I could edit. The closest thing was Hayes ISDN 64k. After doing this I edited the init string and replaced it with the string above. It seems odd to me that it tells me the device is /dev/ttys/7 instead of /dev/ttys0 like I expected. This is an uneditable field too.

When I try to connect it fails and simply says unable to open the connection. I have been wracking my brains over this and am about to give up. Otherwise I quite like Xandros.

Can somebody please help me? I am going to run out of hair at this rate.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...