Jump to content
Sign in to follow this  
flashystylez

Help Me Please!

Recommended Posts

So he has a generic 450 PSU that died and now you are asking him to buy a generic 350 PSU???

 

Anyways back to topic. Getting the PSU for $97 is a good deal. I have an Antec 480 truepower for the past 2 years and i have no single problems at all. Antecs are good.

495974[/snapback]

 

 

cool, thanks for all the help. Im just going to get the antec for a good price. Im praying thats the prob! lol.... Ill keep it posted.

Share this post


Link to post
Share on other sites

you should be praying that it didnt take anything else w/ it. haha i shorted something on my PCP&C and it went out w/ a pop. It handled the short for a while but i kept turnning the system back on trying to figure out what was wrong. then it just gave in and blew up haha. it took my motherboard and cpu w/ it too. plus my HDD is being wierd. im in the process of rma'ing it right now. in fact im installing the new one as i type. i need to sent the bad one back now.

 

*edit* btw, everything was under warrenty so it cost me like $40 to ship everything and it was all replaced. :)

Share this post


Link to post
Share on other sites

did you do the paperclip trick to see if the psu was realy dead??

 

connect the umm i dont remmber sorry.. im sure somebody around here knows.

Share this post


Link to post
Share on other sites

i think its like the orange and the grey wires but im not really sure its been a long time since i did it

Share this post


Link to post
Share on other sites

um.... your using a pc right now????? im shure there is a psu in it, so swop it out and try it.......jeez

 

 

 

its the green one and the black one thats second on the right, let me say this easyer alright , there is one green wire, if you are looking at the connecter fromt the front there is a black wire to the right, you skip that wire and tehre is a nother form the right of that one thoughs are the two you jump with the paper clip.

Edited by pogs16a2

Share this post


Link to post
Share on other sites
um.... your using a pc right now????? im shure there is a psu in it, so swop it out and try it.......jeez

its the green one and the black one thats second on the right, let me say this easyer alright , there is one green wire, if you are looking at the connecter fromt the front there is a black wire to the right, you skip that wire and tehre is  a nother form the right of that one thoughs are the two you jump with the paper clip.

496663[/snapback]

 

 

no, im on my laptop right now, lol. I would have just swapped if I had another pc around to see. But I am almost positive that its the PSU. I will know later today, when I get the new PSU.

 

EDIT: Thanks for all the suggestions and help here! I just got the true control 550 antec, and the psu was the problem. I was able to overclock successfully another 100 mhz! lol. I dont think that I will outgrow this psu any time soon. Never again for generic power supplies. I just took it for granted the cheap cost of generic over the quality of name brand. To think, I could have ruined a 250.00 video card for the sake of a 30.00 psu, lol. Once again, thanks again for all the input!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...