Jump to content
Sign in to follow this  
BiPolar

Grub Won't Boot Xp

Recommended Posts

Okay, so I tried installing FC3 on my IDE hard drive (which currently has two other ntfs partitions (music and page file). My main sata drive has my XP OS partition, and four other partitions for files, programs, etc. I got fc3 up and running, but now I can't boot windows. It just hangs on the boot (screen says rootnoverify (hd0,0)....) The text that is in the grub.conf.

 

How can I get access to my XP again?

 

THis is what my fdisk -l said:

Disk /dev/hda: 80.0 GB, 80054059008 bytes

255 heads, 63 sectors/track, 9732 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

 

Device Boot Start End Blocks Id System

/dev/hda1 * 1 6918 55568803+ 7 HPFS/NTFS

/dev/hda2 6919 7110 1542240 7 HPFS/NTFS

/dev/hda3 7111 9405 18434587+ 83 Linux

/dev/hda4 9406 9732 2626627+ 5 Extended

/dev/hda5 9406 9659 2040223+ 82 Linux swap

 

Disk /dev/sda: 160.0 GB, 160041885696 bytes

255 heads, 63 sectors/track, 19457 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

 

Device Boot Start End Blocks Id System

/dev/sda1 1 5738 46090453+ 7 HPFS/NTFS

/dev/sda2 5739 12113 51207187+ 7 HPFS/NTFS

/dev/sda3 12114 16907 38507805 7 HPFS/NTFS

/dev/sda4 * 16908 19457 20482875 7 HPFS/NTFS

Share this post


Link to post
Share on other sites

ah, you discovered a nice little "feature" about windows! Apparently, windows MUST be on the boot drive (whatever drive your bootloader is on) and be the primary boot device, or else it will not boot. I fought with that same scenario a few months ago on a friend's box. The only workaround I was able to find was to use lilo instead of grub. You can thank M$ for that one.

Share this post


Link to post
Share on other sites

how do install lilo and not use GRUB?

 

<edit> Ok, the problem was I had the wrong partition for my XP boot. It was the fourth parittion, not the first (should have noticed the partition size..DOH!). So everything is fine now.

 

Just have to figure out how to access my NTFS partitions in FC3 now.

Share this post


Link to post
Share on other sites
how do install lilo and not use GRUB?

 

<edit> Ok, the problem was I had the wrong partition for my XP boot.  It was the fourth parittion, not the first (should have noticed the partition size..DOH!).  So everything is fine now.

 

Just have to figure out how to access my NTFS partitions in FC3 now.

440499[/snapback]

 

Should be a simple matter of Mounting the hda(x), but don't try writing or changing anything on them!!

 

For safety's sake, set them to be RO even when you are logged in as Root.

Share this post


Link to post
Share on other sites

yeah, i know...although weird thing is i have a problem now.

 

i used to be able to access the mnt/windows folder, but now i can't, i can only do it as root. How do i give myself permission?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...