Jump to content

Comp Won't Power Up


sandman1485
 Share

Recommended Posts

Well, I took apart my computer to put some AS5 on the CPU (AMD64) and some ceramique on the Northbridge (MSI K8N Platinum). When I removed the heatsink from the CPU it ripped the CPU out of the socket. I made a careful observation of the pins and none of them were damaged, so I sighed in relief. However, upon putting everything back in the case, I cannot power up my computer. The Power LED is lit for my case. The ONLY time the fan spun a bit was while I was removing it a second time to see if it would boot up out of the case. I heard a very very very high pitched buzz, that didn't last too long. I think powered up the computer, and the CPU fan spun at about 5RPM while the buzzing continued. I shut it down, plugged some stuff back into it hoping it was fixed, but no luck. So...I've tried everything I can tihnk of and I'm starting to think it might be my motherboard that's busted. Unless, ripping out that CPU did something...

Share this post


Link to post
Share on other sites

The thermal paste that was on it created a bond. It was the stuff that came supplied with the XP-120 heatsink. I've tried booting up in every possible way. With cpu, without cpu. With ram, without ram. I think i've run out of ways to boot this computer...

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...