Jump to content
HighCharge

MSI RTX 2070 Fan Grinding Noise

Recommended Posts

I bought this gpu a couple days ago and since then it has been making a weird and loud noise every time the fans on the gpu turn on. The gpu itself runs perfectly and has no impact on performance however regarding the fan noise, that is the only problem it has. The sound does get worse depending on how fast it is running. I did make sure that there is no wires touching either of the gpu's fans and anything else. The noise can get very loud at some points and get very annoying. Please give me advice on what I should do.

 

Here's the video of my GPU making the grinding noise as a reference.

Share this post


Link to post
Share on other sites

Yeah it shouldn't be doing that. The fan blade is off balance is my guess and hitting the heatsink. once it spins up, it has enough clearance not be hitting anymore. eventually the blade hitting will break. Send it back if you can, otherwise take the card out and hand spin it to find which blade(s) are hitting and bend it back or trim it off.

I had to do this for my Gigabyte GTX 1070

Share this post


Link to post
Share on other sites

It could be that the fan is not mounted properly.  It may need to be clipped back in to place.  You should interpret the trim it off as sand it down a bit, so that you do not trim the blade off and lower the airflow through the fan.

Share this post


Link to post
Share on other sites

It would be a last resort. Should be able to RMA it. Warranties are usually 3 years. If you cant, than find the blade thats hitting a file, sand or cut it down.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×