Jump to content
dling

Delidding tool i7 8086

Recommended Posts

Have any of you guys used the cheap delidding tools from ebay? Thaey sure are a lot less expensive. I see theres not a reliddend with them also. How important is that?

Share this post


Link to post
Share on other sites

The Rockit 88 delid & relid kit only costs $40,.. and it's not going to damage your chip. 

 

 

Edited by Braegnok

Share this post


Link to post
Share on other sites

Thats what I was worried about. I was think that a 3d printed delidding tool may not be the best idea. I also agree, a dead cpu is a cool cpu. Thanks.

Share this post


Link to post
Share on other sites

Since I bought the Rockit tools 1151 & 2066 socket kits,.. I offered delid service at my shop for $50 and have done a few dozen chips now,.. most folks buying new custom build rig add the delid service. 

Share this post


Link to post
Share on other sites

What do you think about using super glue gel on the corners of the lid to reattach it to the processor ?

BTW took ur advice and ordered the proper tool along with the liquid metal.

Edited by dling

Share this post


Link to post
Share on other sites

Just a "small" drop of the Gel Super Glue in each corner is the way to go,.. it's dry and ready to install in 2-hours. 

 

First chip I used the liquid super glue and it runs all over everything if your not vary careful,.. use the gel. And also do a test drop on a paper towel before hand,..

 

also do a test drop of the LM before pushing plunger over die, sometimes the syringe plunger won't push, and when you push a little harder it will shoot a huge blast of LM all over everything.  :lol:

Edited by Braegnok

Share this post


Link to post
Share on other sites

Glad to help ding. Have fun tomorrow, an get your new hardware together, running @ default settings 100% stable,.. before pulling chip and doing delid.  :cheers:

Share this post


Link to post
Share on other sites

Thanks. I wasn't planning on doing that but it makes sense. Hoping to put it togethet this weekend then. I will post new sig when finished.

Share this post


Link to post
Share on other sites

So here the pics of my deligging from today. It started out so well then Im not sure but I may have screwed it up.

I realized that I did not have the relidding cover all the way pushed on. It tool a bit of pressure, more then I expected.

But of corse I had already added the glue. So I remover the lid for a second time and then the liquid metal had ran over the side of the cpu.

I used tape to clean it up . But the super glue made a bit of a mess and may have caused a bit of a buildup .anyways it all together and running.

I got in such to do this that I had for gotten to do some before temp test so Idont what it was reading .I only have after temps.

post-6219-0-37133100-1536358604_thumb.jpg

post-6219-0-96263700-1536358621_thumb.jpg

post-6219-0-05894400-1536358640_thumb.jpg

post-6219-0-34548500-1536358653_thumb.jpg

post-6219-0-50733400-1536358671_thumb.jpg

post-6219-0-59894500-1536358689_thumb.jpg

post-6219-0-80982000-1536358707_thumb.jpg

Share this post


Link to post
Share on other sites

It should have been a lot easier then I made . The hard way seems to be my way.

Edited by dling

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×