Jump to content
Sign in to follow this  
Patchy

Need help with a tri monitor setup

Recommended Posts

So I purchased a sapphire r9 280x Tri-oc (uefi) which is advertised as being able to run 3 monitors without the need for a display port cable with certain requirements.

 

supports up to 3 display monitor(s) without DisplayPort
5 x Maximum Display Monitor(s) support
To support 3rd monitor without DisplayPort cable connected, 2 of the 3 monitors should be the same model with DVI ports connected. The driver version should be v13.12 or above.

 
My current 2 monitors are the same (dell u2412m's) and hooked up via DVI cables. I'm trying to add a third (not the same monitor) with an HDMI cable. My computer recognizes the monitor but won't output anything  and both my display settings and AMD's CCC won't let me extend the desktop to it. My drivers are up to date as well, something like 14.12 so it's not that.
 
Was I lied too? is there some weird ritual I must perform? Sacrifice a goat? Anything? I just cannot for the life of me get this to work.
 
Attachced is a picture of CCC recognizing the monitor, but beyond that there's nothing. No output, nothing.
 
I've tried sapphire's customer support but they just randomly stopped talking to me, any help would be greatly appreciated.

post-139067-0-96309400-1420521141_thumb.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...