Jump to content
Sign in to follow this  
amhurley

Ultra Products War on Everyone

Recommended Posts

See the attached file about Ultra Products and their war on their competitors and customers.

ULtra.txt

Share this post


Link to post
Share on other sites

Heres the text-

 

A little over three years ago, I purchased an Ultra X$ 1050W power supply. I never would have made the purchase if I had known that Ultra Products is carrying on a war with its competitors that affects its customers in obnoxious and irritating ways.

 

A few weeks more than three years ago, I purchased the largest power supply they make, a 1050W Model X4. It worked well in a server computer.

That server needed an upgrade and that is where the problems began. After the system was assembled, the power supply would provide power to the motherboard. I could tell that because a small led on the motherboard lit up. When the on button was pressed, there was an almost inaudible "click" and then nothing.

 

I followed the directions in the manual for the motherboard. I disconnected the DVD and the hard drive. No change. Then, I disconnected the two 4x2 PCI-E cables from the video card. The fans started up and everything started to work. Reconnecting the power cables produced a no start condition. I thought I had the problem isolated and I blamed a bad video card. There was one puzzling thing, though. I had been using that video card for several years and it had been working perfectly. Why had it decided to quit now?

I placed telephone calls to the support staff for the motherboard and for the video card. Neither told me there was any incompatibility, and they could shed no light on the problem.

 

Many years previously, when I purchased a power supply like the Ultra X4 which has the modular ports on it for the cables to plug in, I had accidentally plugged just one cable in backwards. Nothing worked. Therefore, I started to focus in the cables.

Like a lot of people, I had thrown all of my unused cables for various systems I had built over the last few years in a box just in case I needed one. I had presumed that all of these cables from different manufacturers were generic and I could use them as needed regardless of the power supply.

After a bit, I began to think there was something different about the Ultra cables. Each of PCI-E cables had an odd bulge in the insulating tape near one end and they were all "peel away", i.e. two of the eight connectors peeled away from the others on one end so that they could end up not being used. My other cables did not have these features.

 

There was also a mystery regarding one of the ports on the side of the power supply. While there were three ports that fit the PCI-E cables, one did not. There was no special color or designation for this port. It just didn't fit the connector and the difference was so small that I couldn't figure out the exact reason.

It was at this point that I called Ultra support, and that is where the true nature of the problems began to unfold. Their support person told me that I should use only the PCI-E cables that came with the power supply. These cables were proprietary in design and made specifically so they would work only with the X4.

I asked their support person for a case number so that I could determine the correct cables, try them out and then report back. Unfortunately, their support person would not give me a case number. He said, "Unless we are replacing something, we don't give out case numbers." So, I was on the telephone with the support person for a very long time as all of the events unfolded. I was able to isolate two Ultra PCI-E cables . They had a tie attached to each with "ULTRA" written on it. I installed these cables. There was still a no start condition.

 

The Ultra support personnel suggested that I had a bad video card and suggested that I try a different one. While I was doing this, the line was disconnected.

I went ahead and tried a different video card, but the no start condition persisted. It was not a video card problem.

I called back and talked to a different person. It was impossible to get the original person to come to the telephone, and so I had to start all over.

I asked about the one port on the side of the power supply that would not fit any of the cables supplied. I was told that this was a special port for a special 4x2 cable that attaches to some motherboards. It was explained to me that this was a different type of 4x2 port and so, to prevent damage, it was designed so that it would not fit any of the PCI-E cables. I examined the user guide for the X4 and it did not contain this information.

I looked at my motherboard and I saw that I had the type of motherboard that required the 4x2 cable. . I pulled out the cable and looked at it. Then, I started the power supply. All of the fans went on. Putting the cable back in resulted in a no start condition. Pulling the cable back out resulted in the fans going on. Finally, I had a repeatable problem.

 

I could see that I had used a cable from a different power supply. I asked Ultra support specifically if this would cause a problem. At first, I was told that it would not. Then, I was told that it might. I really didn't get a definitive answer on this. Later, Tiger Direct told me that it definitely would.

With the problem now looking probable as an incompatible power cable, I did the logical thing: I looked everywhere for it. But, it was no where to be found. I asked Ultra Products to send me one. I said, "It has been a little bit over three years but, to tell you the truth, I don't think I ever had it. Can you send it to me? The power supply is advertised as having a Lifetime Warranty."

The reply was, "You only get a LIfetime Warranty if you register the power supply. I can't find any indication in our records you ever did that. Because you did not register, you are entitled only to a three year warranty and that has expired."

I said, "I always register things if the directions say to do that. Where was the direction to register? I have the directions for the power supply right here in front of me and there is no such direction."

 

The reply was, "It was on the outside of the box. That is where we put it."

I said, "I didn't expect a warranty there and I remember I threw out the box right after I got the X4. Besides that, three year period has only been up for two weeks. Can't you make an exception? I'll register right now, and I can send you a PDF file from Tiger Direct showing you the very day I made the purchase."

The reply was, "I'm sorry, you are too late to register." If you want to get the cable now, you will have to purchase a completely new set from Tiger Direct."

Apparently, Ultra was the first to manufacture the type of power supply with the modular ports. When other copycat manufacturers started to make them, Ultra went to war against the other manufacturers, without consideration of the irritation it would cause their customers.

Ultra sued all of the other manufacturers. Then, they changed their cables so that only Ultra cables can be used and they changed the ports on their power supply so other manufacturers' cables would not fit.

 

The end result was that there was so much after market demand for the special Ultra power cables that they decided to make money on the situation by making cables available only in a complete set. The sneaky way the warranty was presented (only on the outside of the box) and the sneaky way it was implemented (requiring registration), was the way they increased demand for the cables.

You can check for yourself. The cable set is available through Tiger Direct, part U12-40950.for $40.

Edited by Andrewr05

Share this post


Link to post
Share on other sites

Heh, I just thought it fishy with it being his first post and all. :P

 

Not sure why he didn't just copy/paste.

Share this post


Link to post
Share on other sites

Heh, I just thought it fishy with it being his first post and all. :P

 

Not sure why he didn't just copy/paste.

I uploaded it to google docs and then copied the contents, I wasn't going to execute it locally just in case. :P Edited by Andrewr05

Share this post


Link to post
Share on other sites

Always be very suspicious of files that are not picture files, I'm even leary of links from first time posters .Too much crap out there these days .

  • Like 1

Share this post


Link to post
Share on other sites

This is a "war on everyone"?

 

Using modular cables between power supplies is ALWAYS a no-no. Their support may not be the greatest but I don't see any war here. :lol:

Share this post


Link to post
Share on other sites

I see 95% user error, 5% Ultra could have handled it better.  Seriously a LOT of companies have went to register or you get a more limited warranty and chances are you read about that lifetime warranty on the box in the first place and should have taken a few seconds to read the fine print associated with it.  Next any time you're dealing with power DO NOT MIX UP CABLES.  That's just asking for trouble and I wouldn't blame Ultra one bit for voiding the warranty at that and moving on. While on the subject of Ultra, they haven't really been known for putting out the highest of quality PSUs so why would you choose them (and a 3yr old consumer grade version on top of that) for a server!?!?!? 

 

As for replacement cables...I fail to see how you losing the appropriate cable (and after 3yrs I'm going to assume you misplaced it because I would have to did for the extra cables for all but the BP-550 in my server (which is desktop parts on a shelf btw with the extra cables on the shelf above it) is Ultra's fault.  And as for selling replacement, most companies that make modular power supplys do, here's a link to what SIlverstone offers for example.

 

I don't usually like to be this hard on someone especially here at OCC, but when you create an account for the sole purpose of shooting down Ultra's name and can't even be bothered to post it other than in an unformatted  text document with no links to anything you reference, see it's not hard to track down the cable kit you mention. Seriously, took a few seconds to do that even if I did decide to link to Walmart instead of TigerDirect, but that should make you happy as both TigerDirect and Ultra Products are both entities of Systemax anyway so I know you would hate to see me link to TigerDirect.

 

If you want to bash Ultra's crap products, do it right with a handy link like this one. Nothing like their "1200w" PSU having a hard time getting there, and I quote:

 

 

The Bad:

  • somewhat sloppy build quality
  • no overtemp shutdown until it was almost too late
  • one must run the combined 3.3V and 5V rails almost wide open to get to 1200W

The Mediocre:

  • efficiency below standard 80 Plus certification

 

Now if you would like some help finding a well priced replacement that will run what you need it to, feel free to post of this system's full specs and any planned expansion a long with your requirements and myself and I'm sure several others will be happy to make some recommendations that wont leave you as upset as the Ultra has.  Or if you want to research on your own I would recommend the site I linked for the Ultra review above, bit of strange humor but one of if not THE best PSU review site I've found.

Share this post


Link to post
Share on other sites

Can we stop using the word war like this? I feel like it completely dimishes the value and impact that the word used to have, and we have no substitute anymore. Also why would you post a text file, it feels like the OP doesn't really know anything about computers. Also why on Earth would you think all modular cables would be generic? Computers parts are like car parts, you need the right part that's compatable, you woudln't expect an Alternator from a Ford to work in a Volkswagen would you? A mod should delete this thread because this is obviously just spam.

Edited by OrangeJuice

Share this post


Link to post
Share on other sites

With all the above here. Nothing really out of the ordinary. I think a good deal of the electronics i have purchased over the last year came with no warranty information in the box, though i do it all online so it makes no difference to me.

Share this post


Link to post
Share on other sites

On another note, I've been using 2 ultra psu's for over 2 years without a problem, but then again I've never plugged the cables in the wrong sockets, and if I did I could not blame ultra if they blew up.

Share this post


Link to post
Share on other sites

1050W for a server?

 

They aren't the best power supplies out there but they are far from the worst.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...