Jump to content
Sign in to follow this  
Justhavocman

Anyone else encountering problems with the Nvidia R331 Game ready driv

Recommended Posts

So far i've tried installing it  on two separate computers , on my main it simply won't install the driver by saying " installation can't be completed" and on my side rig which i installed the driver i get random blue screens and weird game glitches. Anyone else on the same boat or is it just me?

Share this post


Link to post
Share on other sites

Installation went off without a hitch for me. I haven't tried any games.

 

Note: I did "custom installation" (so I can uncheck the 3D Vision crap) thru the GeForce Experience client.

Share this post


Link to post
Share on other sites

This may be a silly question, but you rebooted after installation, right?

 

My advice would be to try a clean install. Uninstall all nvidia software from the control panel and download the installer from their website. Try that.

Share this post


Link to post
Share on other sites

This may be a silly question, but you rebooted after installation, right?

 

My advice would be to try a clean install. Uninstall all nvidia software from the control panel and download the installer from their website. Try that.

While I certainly suggest that in justhavoc's case, I would just like to note that ever since installing GeForce Experience and using that to update drivers, I've never done a clean install and have never had to restart after updating my drivers. I definitely recommend every NVIDIA user to install GeForce Experience as it really does make things easier even if you don't use it to auto-update game settings (which I don't).

Share this post


Link to post
Share on other sites

Installed it, and had to hard reset my computer because both monitors just went black for about 15 minutes. After the reset, I checked it, and it seemed to work fine. Not sure what that was about.

Share this post


Link to post
Share on other sites

Several people were getting corrupt driver downloads via the GeForce Experience (myself included on my GTX 770 SLI rig) but then many are having no issues, if you have problems and dont want to do a clean install getting the driver straight from geforce.com seems to work without issues. I'm guessing one of the DL servers out there didn't get the correct files initially and caused the issues but overall I too like the convenience of the new software (of course AMD users have more or less the same thing branded for them now too)

 

Now if only nvidia would give back compute performance for older cards.  Sucks for [email protected] users when you have to choose roughly triple PPD or the option to play games like BF4 all because of them trying to keep people from buying consumer grade cards for workstation tasks (at least I assume that's the reason as those cards on the same architecture are unaffected with newer driver revisions and neither are the 780/Titan cards)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...