Jump to content

Recommended Posts

need some help. Building my first Bit Fenix rig but am stuck. This plug comes off the 24 pin connector on its own thin cord. the 24 pin connector is already plugged in. The 8 pin board connector is already plugged in as well. Where do I plug this thing in? its a seasonic 760 platinum power supply.

I can't find anywhere on the Asus Maximus Impact for it to go. I searched everything online but no luck.

what is this mystical PSU cord thing and where does it go? thanks guys.

 

 

 

you can see the little cord coming off the 24 pin connector here as well.

 

 

post-124843-0-38920800-1385252997.jpg

post-124843-0-10123500-1385252999_thumb.jpg

post-124843-0-70138300-1385253000_thumb.jpg

Share this post


Link to post
Share on other sites

Are you sure that's a genuine Seasonic lead? It looks nothing like I've seen before on a power supply.

 

I'm using a Seasonic X-Series 760W and that certainly doesn't have that connector.

 

Going of the wire colors it has +5VSB and +3V3 which is very strange?

Share this post


Link to post
Share on other sites

Yeah it is. The picture shows clear plastic on the ends but mine is really all black, like the rest of the cords. 

 

Computer starts without it, but its weird to have just this spare cord. 

Share this post


Link to post
Share on other sites

What's the model number of the power supply?

 

I'd have to say that the lead you've shown isn't what's usually supplied by Seasonic.

Share this post


Link to post
Share on other sites

The lead you've linked to shows three blacks and a red (0v & +5V) so not the same?

 

If you've bought a genuine Seasonic power supply then I suggest somethings not quite right!

Share this post


Link to post
Share on other sites

It's not a Genuine SeaSonic 24-pin connector,.. :wacko:

Edited by Braegnok

Share this post


Link to post
Share on other sites

I was showing that for reference. After more research, I've discovered that its a Japanese version of the PSU.

they released a product only in Japan that it is compatible with. 

 

Here's the link for those interested....in Japanese of course. 

 

http://www.gdm.or.jp/crew/2012/1225/15469

 

From the color of the wires it looks like a 5V connector, which should not be there at the first place.

Although the existing PSU will work without any problem ,you could contact Seasonic and ask them to provide you a normal model of X760.

Share this post


Link to post
Share on other sites

Modular power supply, probably just shipped some connection "bags" with the Japanese cable included.

Possibly they sold more power supplies outside Japan, and less inside, then expected.

Easier to send any "cable" bags excess to needs worldwide than stockpile.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...