Jump to content
Penti

Asus Maximus V Extreme PCI-E Slot for Dual GTX 690

Recommended Posts

Not sure if this goes to this board or the GPU one, but I'm thinking it's more of a MB question than a GPU one.

 

I recently bought a Maximus V Extreme with two GTX 690s. When I installed them on the motherboard via the first (1A) and third (2B) PCI-E slots (as instructed in the manual), the motherboard doesn't detect the second 690 (connected to the 2B slot). After interchanging both GPUs and nothing worked, I tried connecting the second 690 to the second slot (2A), the motherboard was able to detect both. Is this correct since I'm suppose to refer to Quad-SLI and not SLI for positioning since a 690 is already in SLI?

Also, what's the optimal positioning for the second 690 since being connected to the 2A slot, it's sitting next to the first 690 which limits airflow.

P.S. haven't done benchmarks yet, would rather get an answer here before tinkering to limit chances of damage to the cards.

Thanks in Advance!

 

Share this post


Link to post
Share on other sites

They should be detected no matter what assuming you have all of your drivers installed properly. Did you install the chipset drivers for your motherboard? Since that board has a secondary PCIe chip you might not be able to use the lower slots without installing the driver.

Share this post


Link to post
Share on other sites

I remember that I did install the drivers that came with the MB, but I'm not sure if the ones for chipset was included in the pack or if I need to install them separetely. Might update BIOS and drivers and see hot it goes.

 

If I'm not mistaken, you might be right about the secondary chip. Will update here if I get it working.

Share this post


Link to post
Share on other sites

IMHO I would RMA the board, sounds like an issue with that slot or maybe the bios. but wow GTX 690 SLI, awesome dude! :thumbsup:

Share this post


Link to post
Share on other sites

@sword_fish

 

I've read that part, my other PCIe slots are empty, except for the PCIe x1 for a soundcard, but that isn't included in the list that would disable the 2B slot.

 

Still haven't moved the GPU back to the 2B slot after reinstalling board drivers, will try it tonight and see how it goes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...