Jump to content
ClayMeow

Watch Dogs

Recommended Posts

That's weird because one article I saw that compared performance between the 290X and 780Ti had the 290X actually beating it almost all the time (all the time with Ultra textures thanks to the extra 1 GB of RAM, but at just High textures they were more even).

Share this post


Link to post
Share on other sites

cchalo, are any of your components OCd? Maybe it's not as stable as you think and you should dial it back to see if that helps.

Share this post


Link to post
Share on other sites

 

I am so frustrated right now with this game. It's unplayable for me. I can't rotate my view even a few degrees without my HDD light going solid and the game juttering to a halt. If I keep the camera perfectly centered, not moving a thing, it's super smooth! 

 

I'm trying to run the game at 1440p with HBAO set to low, TXAA 2x, and detail set to high. These aren't even max settings. Even AC4 runs fine at max for me. And from the little I've seen it looks superior, as well. 

 

Every single time I preorder a game I get burned. Can't believe I shelled for the digital deluxe. Shame on me.

Did you check what GFE says is the optimal settings?

 

I'd also try running 1080p instead (windowed if you don't want distortion) and see if that helps.

 

Or look thru this.

 

 

The guide is new to me, thanks for showing me that. My frustration remains, though, because I shouldn't HAVE to do any of this. I have better looking games on my PC that run better. It's hard for me to knock things down a few notches just out of principle. 

 

Is there a reason this game won't use more than 2GB of RAM for me? I'm sitting here with the game running and I'm only using 36% of my memory. Why on Earth wouldn't they program the game to cache in the memory rather than the HDD? That's why it's frickin there!!!!

Share this post


Link to post
Share on other sites

 

 

I am so frustrated right now with this game. It's unplayable for me. I can't rotate my view even a few degrees without my HDD light going solid and the game juttering to a halt. If I keep the camera perfectly centered, not moving a thing, it's super smooth! 

 

I'm trying to run the game at 1440p with HBAO set to low, TXAA 2x, and detail set to high. These aren't even max settings. Even AC4 runs fine at max for me. And from the little I've seen it looks superior, as well. 

 

Every single time I preorder a game I get burned. Can't believe I shelled for the digital deluxe. Shame on me.

Did you check what GFE says is the optimal settings?

 

I'd also try running 1080p instead (windowed if you don't want distortion) and see if that helps.

 

Or look thru this.

 

 

The guide is new to me, thanks for showing me that. My frustration remains, though, because I shouldn't HAVE to do any of this. I have better looking games on my PC that run better. It's hard for me to knock things down a few notches just out of principle. 

 

Is there a reason this game won't use more than 2GB of RAM for me? I'm sitting here with the game running and I'm only using 36% of my memory. Why on Earth wouldn't they program the game to cache in the memory rather than the HDD? That's why it's frickin there!!!!

 

I have no clue. Are you sure you haven't messed around with some setting outside of the game that would affect it? The game uses 8GB of RAM for me almost immediately upon launch...so it only using 2GB RAM for you is extremely odd and has to be the reason you're getting so much HDD activity and stutter.

Share this post


Link to post
Share on other sites

cchalo, are any of your components OCd? Maybe it's not as stable as you think and you should dial it back to see if that helps.

On that rig, no actually.  Still waiting on the H100i to get back from Corsair so the cooler on the 4930K doesn't give me the headroom I want to keep an OC on it and the 290X doesn't really need it.  

 

I did get around to playing on the other rig, and while I went with the default high settings it's running much smoother though it still spends WAY too much time below 50 fps during medium speed driving and above.  (The 4770K and GTX 670 are OCed) The game based on my two rig sample just seems to really prefer nvidia as far as a stable frame rate.  

Share this post


Link to post
Share on other sites

 

 

 

Ok, so that's actually REALLY interesting to me. That's most definitely why I'm having issues, then. Yeah, the game will hit 2GB and then stop. I wonder why that is?

Share this post


Link to post
Share on other sites

 

 

 

 

Ok, so that's actually REALLY interesting to me. That's most definitely why I'm having issues, then. Yeah, the game will hit 2GB and then stop. I wonder why that is?

 

So sad...nobody reads my review :cry:

 

Second page, I wrote: "Watch Dogs' system requirements list 6GB RAM as the minimum, with 8GB recommended. Using MSI Afterburner's RivaTuner Statistics Server (RTSS) to display in-game RAM usage, I surpassed the 8GB mark soon after loading the game (out of my 16GB total), using a mix of Ultra and High settings, TXAA, and HBAO+."

Share this post


Link to post
Share on other sites

Is there a reason this game won't use more than 2GB of RAM for me? I'm sitting here with the game running and I'm only using 36% of my memory. Why on Earth wouldn't they program the game to cache in the memory rather than the HDD? That's why it's frickin there!!!!

 

 

Make a shortcut to your watch_dogs exe and add " -disablepagefilecheck" to your target after "

 

The above should help 

Share this post


Link to post
Share on other sites

 

Is there a reason this game won't use more than 2GB of RAM for me? I'm sitting here with the game running and I'm only using 36% of my memory. Why on Earth wouldn't they program the game to cache in the memory rather than the HDD? That's why it's frickin there!!!!

 

 

Make a shortcut to your watch_dogs exe and add " -disablepagefilecheck" to your target after "

 

The above should help

I'm actually using that currently, as a matter of fact. The memory usage remained unchanged regardless if I had that or not.

Share this post


Link to post
Share on other sites

My son is running a i5 2500k, sapphire HD 6950 graphics card, 8 gb ram (no oc on anything). When hit "enter" to play the game his cpu hits 100% and he gets the blue screen. We will try to update his graphics card tonight but I don't think thats it. Any idea what the problem could be? 

   Sorry guys for the triple post.

Edited by peshewah

Share this post


Link to post
Share on other sites

 

 

Is there a reason this game won't use more than 2GB of RAM for me? I'm sitting here with the game running and I'm only using 36% of my memory. Why on Earth wouldn't they program the game to cache in the memory rather than the HDD? That's why it's frickin there!!!!

 

Make a shortcut to your watch_dogs exe and add " -disablepagefilecheck" to your target after "

 

The above should help

I'm actually using that currently, as a matter of fact. The memory usage remained unchanged regardless if I had that or not.

 

I do not use that flag, so sadly no surprise that it wouldn't help your issue.

Share this post


Link to post
Share on other sites

 

 

 

Is there a reason this game won't use more than 2GB of RAM for me? I'm sitting here with the game running and I'm only using 36% of my memory. Why on Earth wouldn't they program the game to cache in the memory rather than the HDD? That's why it's frickin there!!!!

 

Make a shortcut to your watch_dogs exe and add " -disablepagefilecheck" to your target after "

 

The above should help

I'm actually using that currently, as a matter of fact. The memory usage remained unchanged regardless if I had that or not.

 

I do not use that flag, so sadly no surprise that it wouldn't help your issue.

 

 

Clay do you have Pagefile enabled in Windows at all ? I know it is quite commonplace for users with 16Gb+ Ram to disable it completely to speed things up, and I also have it disabled.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...