Jump to content
cali101

Desktop won't connect to the internet...

Recommended Posts

I've just moved back home from uni and for some reason, my desktop can't access the internet. It does connect to the router without trouble.

 

Every other device here works fine so I doubt it's a problem with the router itself. I also doubt that it's a hardware problem, since it worked fine at uni. I've tried many suggestions to no avail, including:

 

Rebooting the modem and router,

Making sure the wifi card drivers are up-to-date,

Putting the wifi card in a different pci-e slot,

Flushing the dns in the command prompt,

Releasing / renewing my local IP,

Setting the IP, subnet mask, DNS etc manually - I tried both my ISP's DNS and Google's DNS (8.8.8.8),

Using the RAlink program instead of the 'network and sharing centre',

Seeing if it works in 'safe mode with networking' (it doesn't),

Making sure my wifi card supports my network's encryption (WPA2 AES) - it does.

 

I tried accessing the router's settings from the desktop and the page just times out. I also get no response from the router when I ping it from the cmd, and also no response when I ping the desktop from the router. It does, however, show up as connected on the router and on the desktop.

 

My router is a D-Link DIR-615 and my modem is a Netgear DM111P. My wifi card is an RALink RT2890.

 

I have a feeling re-installing windows will fix it, but I'd rather not if I don't have to. Is there anything I've missed? :P

Share this post


Link to post
Share on other sites

Hey Cali, what version of Windows are you running?  Have you already attempted to reset/repair Winsock and Winsock2 (if running Vista or Win 7)?

 

That would be my first attempt at fixing.  If that fails remove the hardware (your wireless card) using the Windows Hardware Manager - when it asks if you want to delete the driver software for this device choose "Yes".  Now use the Windows Programs and Features (assuming Vista or Win 7) utility to remove any other Ralink supporting applications.  Before rebooting manually search and remove all files and folders pertaining to Ralink - do the same in your registry.  

 

Before deleting registry values make sure to create a backup of your registry.

 

After that is done, physically remove the wireless card and boot into Windows one time.  Run a quick search through your files and folders and make sure all Ralink files and folders are gone.  Do the same in your registry.

 

Now power down, reinstall the wireless card and boot into Windows.  Windows new hardware wizard should start.  If you're running Win 7 it might find and install a generic wireless card driver.  If so try to access the internet. If you still cant, then go ahead and install the 3rd party drivers for the card.

Share this post


Link to post
Share on other sites

Since you're trying to connect by WiFi, Is MAC Address filtering on or off in the router?

Share this post


Link to post
Share on other sites

That is another great question kyfire.  Along those same lines, make sure that there are an adequate number of DHCP addresses assigned in the router.

 

As an example, your router is configured to assign DHCP IP addresses 192.168.0.100 through 192.168.0.105.  However there are already six devices using up all the available IP addresses leaving you "out in the cold".

Share this post


Link to post
Share on other sites

Since you're trying to connect by WiFi, Is MAC Address filtering on or off in the router?

 

It's off.

 

I've just reset winsock and now it doesn't even say it's connected. It just says: "Unidentified Network" and "Limited Access". I'm trying the other solution now...

 

I'm on Windows 7 by the way.

Share this post


Link to post
Share on other sites

Ok, keep us posted.  

 

When you reset Winsock you probably would have had to go back in and manually set up your wireless connection.  But that's ok.  Going with solution #2 is likely going to iron everything out for you any way.

 

Good luck.

Share this post


Link to post
Share on other sites

That is another great question kyfire.  Along those same lines, make sure that there are an adequate number of DHCP addresses assigned in the router.

 

As an example, your router is configured to assign DHCP IP addresses 192.168.0.100 through 192.168.0.105.  However there are already six devices using up all the available IP addresses leaving you "out in the cold".

 

It's set to assign addresses from 192.168.1.100 to 192.168.1.199, so that shouldn't be a problem.

 

There's one registry entry left that I can't delete as it says "access denied", even when I run regedit as administrator. It's at:

 

HKEY_LOCAL_MACHINE/SYSTEM/ControlSet001/PCI/

 

The rest are gone though.

 

I put the card back in and it said "Windows cannot load the drivers required for this device (Code 31)", so I installed the third party drivers and it still says the same thing...

 

[EDIT] Just to clarify, It was the only entry left that mentioned "ralink".

Edited by cali101

Share this post


Link to post
Share on other sites

Ok, I've restored the registry back to where it was before I deleted anything and it's connecting to the router again. Still no luck with an internet connection though

Share this post


Link to post
Share on other sites

Assign a static address in the network card and check the presence of gateway.

You should be able to ping the gateway if the network is working flawlessly.

Share this post


Link to post
Share on other sites

Ok, I've restored the registry back to where it was before I deleted anything and it's connecting to the router again. Still no luck with an internet connection though

 

Please check whether you can ping the gateway or not.

Share this post


Link to post
Share on other sites

Ok, we'll try and start at the beginning and work this through.....

 

What is the gateway address of the router?  Open the router configuration page from one of the PCs that is accessing the network without issue and please provide the gateway address.

 

Now, open a command prompt on your machine and type "ipconfg /all" without the quotation marks and post up a screen shot of those results.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...