Jump to content
panjang110

low fps on an 8 year old game

Recommended Posts

hi guys, i just installed Star Wars Knight Of The Old Republic game but i'm getting average 25-30 fps and sometimes even lower with my on board HD3300, 8 years ago i get at least 50-60fps out of my old P4 and geforce 4Ti....is this some sort of a driver issue or just some setting problem? i have tried running it in all windows compatibility mode and it's still the same :down:

Share this post


Link to post
Share on other sites

i think hd3300 is faster cause i remember going from a vanilla 6600 to HD3300 gave me almost 25-35% more performance ...

Share this post


Link to post
Share on other sites

well unfortunately the game only support up to 1280x1024 res, even at low 800x600 the fps is still the same and i'm not getting any improvement... i think amd chip doesn't like old OpenGL games cause i've just put in my old 8800gt and i get 100++ fps...

Share this post


Link to post
Share on other sites

Just before anyone suggests it and you ruin your chip; of you ar using the Northwood architecture, be VERY careful increasing voltage when overclocking :thumbsup:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...