Jump to content
Sign in to follow this  
NCC10281982B

Crontab & Time zone problem

Recommended Posts

I have been wrestling FBCMD for months. My newest problem is the virtual private servers time zone. S3hlls (the hosting company) says it is located in Chicago. But, when run the date command in the shell it outputs

Sat Sep 29 19:42:33 MSK 2012

Thhis is Moscow standard time according to google. I have scripts that I want to run on PST. So I would like to how how to change the system timeszone. I have already changed the TZ in the hosting control panel to PST. No effect. What do i need to do to make this right?

Share this post


Link to post
Share on other sites

Can you access /etc/localtime and /usr/share/zoneinfo/ ?

 

If so, delete/move /etc/localtime and then create it as a symbolic link to an appropriate zoneinfo file.

 

i.e.

ln -sf /usr/share/zoneinfo/America/Chicago /etc/localtime

Share this post


Link to post
Share on other sites

Can you access /etc/localtime and /usr/share/zoneinfo/ ?

 

If so, delete/move /etc/localtime and then create it as a symbolic link to an appropriate zoneinfo file.

 

i.e.

ln -sf /usr/share/zoneinfo/America/Chicago /etc/localtime

 

 

I get bash: ln: command not found

 

What does it mean? Do I have to install ln?

Share this post


Link to post
Share on other sites

What OS are you using? I would think that ln is available on all Linux operating systems. Creating links is rather common.

Share this post


Link to post
Share on other sites

What OS are you using? I would think that ln is available on all Linux operating systems. Creating links is rather common.

:withstupid:

 

Are you logged in with root access also? Some hosting companies disable a lot of common commands for non root users.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...