Jump to content
WhenKittensATK

Windows 8 Compresses Wallpaper

Recommended Posts

i don't mean to be a bagger but aside from built in mobile device management i really haven't found any major improvements in win 8, and no good reason to change from win 7....imma leave it all alone until something better comes along...

Share this post


Link to post
Share on other sites

I tested this myself and cannot find the issue you have shown. Also my background image files are not changing size not sure why yours are.

Share this post


Link to post
Share on other sites

ARG! I'm trying to find the source as a reference, but I know I read on msdn or technet that for Windows 8 had a custom image algorithm to use on the wallpaper and various images to reduce resource use and speed up the UI.

 

It didn't sound like they saved a compressed copy, but then again I wouldn't doubt there's a decision tree based on random variables as to handle things like the wallpaper.

Share this post


Link to post
Share on other sites

They've done this since Vista AFAIK, but it's been cranked up in Windows 8

 

A simple way around it is to open your image in IE10 and use that to set the desktop image (right click on the image, context menu etc...) - this seems to bypass the compression.

This of course works better if your image is in an uncompressed format to start with.

Share this post


Link to post
Share on other sites

I had this problem myself, searched endlessly for an answer and found none. Until I found someone who did not have this problem, I asked them to share their wallpaper with me and I tried it, sure enough, their wallpaper did not have any on screen artifacts and the resulting compressed wallpaper, was not a shrunken down jpg. In fact, the file size of the "compressed" jpg was larger than the original.

 

So I decided to look around into the settings on the jpg, nothing unusual that I could see, the image was 1900x1200 at 72.009dpi and 8bit. I decided to scale down my own personal wallpapers to the 1900x1200 size, changed the dpi and bitrate to match the other jpg. After saving my new image, I right clicked on it and chose set to desktop, the resulting image has no artifacts and is no longer compressed. This works for every wallpaper I have.

 

If you try this, I think you need to make sure you change the image dimensions to match that of what your screen resolution is exactly. Also making sure the dpi is set to 72.009 and 8bit. Try it out, see if this helps anyone. I will be posting this message on all the forums and blogs I see discussing this.

Share this post


Link to post
Share on other sites

Heck! Thanks to everyone who contributed. I'd like to contribute my problems and solution:-

I wanted to use a 1.5MB bmp as the desktop behind the Windows 8 "normal programs" screen, but it's old so it's not wide enough for a modern screen. So Win 8 does two things, loses the detail by using compression and enlarges the photo width to fill the screen, so losing the bottom of the picture.

My solution:-

Use Picasa menus to Create, Set as Desktop; then right click on the taskbar to show the desktop, personalise, pick the photo, Center it and save. Works!

Regards, Nigel

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...