Jump to content
Sign in to follow this  
BronsonTheGod

Need Some Help With An Audio Issue

Recommended Posts

Hey guys, I seem to be having some trouble with my on board sound. I did a fresh install of windows and Installed all the newest drivers, everything seems to be working perfectly except my on board sound. I can see my Realtek drivers in the device manager and it says it's working properly and I'm dead sure I installed them correctly. It seems the only way I could get sound was through my Graphics cards HDMI ports. (Speakers plugged in the monitor to achieve sound) Which then lead me to the idea that my graphics card driver was blocking my realtek but I had no problem before I installed windows and I even tried disabling all the Nvidia audio drivers with no result. Any help would be appreciated and I'm sorry if I didn't give enough information, thanks in advance.

Share this post


Link to post
Share on other sites

Which version of Windows are you running?

 

On Win XP: In your system tray, right click your speaker icon and select "Adjust Audio Properties." Select the "Audio" tab, then for "Sound Playback" select your sound card.

 

On Win 7: In your system tray, right click your speaker icon and select "playback devices." Click on "Speakers Realtek High Definition Audio" and click the "Set Default" button. Click "OK" then restart any apps that use audio.

Share this post


Link to post
Share on other sites

In the Playback Devices manager in Windows, does it show the video card HDMI out there? If it does, right click it and then select Disable. Then it should default to your onboard audio.

Share this post


Link to post
Share on other sites

Thanks BP, tried that even tried uninstalling the Nvidia sound drivers and even disabling them in the device manager. I've searched for this problem and people say they need to buy a new soundcard. Hoping thats not my only option here.

Share this post


Link to post
Share on other sites

Have you checked the BIOS to make sure the onboard audio is enabled? I know it sounds rather simple, but never hurts to be sure.

Share this post


Link to post
Share on other sites

Windows 7 wouldn't normally install the default Realtek sound drivers if the onboard sound was disabled via BIOS, but I guess it's possible. Before you attempt a fresh Windows 7 installation you can try this;

 

Remove both your video card and sound card using device manager. When asked if want to delete the drivers as well, select yes.

Use DriverSweeper to remove any remaining remnants of ATI, nVidia and Realtek drivers. Careful here, don't choose to remove any items not related to sound or video.

 

Reboot the computer, enter BIOS and disable onboard sound. Go ahead and boot in to Windows. Install video card drivers but do a custom installation instead of default or express installation. During custom installation you'll be given the option of what you want to install. Select only the video card driver and CCC (if AMD card) or video card driver and Physx (if nVidia card). After installation reboot and make sure video appears to be working ok. Open up your device manager and under sound devices the only thing you should see is generic hd audio device. Now reboot the computer, enter BIOS and enable onboard sound. Proceed to boot in to Windows and let Windows install the default audio drivers.

 

After completion another reboot may be required. Get back in to Windows and check to see if you have sound.

 

Other simple things I can think of;

 

Are your speakers connected to the correct audio out jack on the motherboard (that port is usually color coded green)

If speakers are powered or amplified are they plugged in and is there some visual indicator (i.e. a power light) that they are getting power

Have you tried another analog audio cable?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...