Jump to content
Sign in to follow this  
stackrainer

Can't make servers after reformating

Recommended Posts

Well guys, I took the plunge and reformatted to windows 8 beta. I can't exactly tell you how well it performs for video games (because I'm still working on getting DX11 and all the good stuff). But anyways I reformatted because I could not fix my computer so that i could host servers for minecraft and mumble. After reformatting and trying to get a server up I found out that my freinds still could not join (although people on my network can). Idk what happened but I just cant host any servers anymore. I made a few changes to the regisrty, and i think that messed it up.

here are the changes i made:

 

typed "netsh interface tcp set global autotuning=disabled" into cmd

followed this video:

I'll save you 10 min and say i added this to the registry into the current set folder TcpAckFrequency TCPNoDelay It used to be the old wow trick to lower latency problems

Share this post


Link to post
Share on other sites

If you don't have a valid external IP address to give them along with forwarding the ports from your router to your machine you're not going to be able to host anything.

 

I'm betting you had it set up before on the router but you didn't update it when you reformatted (which will usually cause your NIC to get a new IP address).

Share this post


Link to post
Share on other sites

If you don't have a valid external IP address to give them along with forwarding the ports from your router to your machine you're not going to be able to host anything.

 

I'm betting you had it set up before on the router but you didn't update it when you reformatted (which will usually cause your NIC to get a new IP address).

I think your the only one that gave me a good answer over several minecraft forums... thank you. Anyways ill get to test it when someone trys to get on the server.

Share this post


Link to post
Share on other sites

Make sure windows firewall is "off" or an exception is in place to ignore 25565 and insure that your internal IP is the same as what's listed on your router page as Waco suggested.

Share this post


Link to post
Share on other sites

Make sure windows firewall is "off" or an exception is in place to ignore 25565 and insure that your internal IP is the same as what's listed on your router page as Waco suggested.

I did made an exception in the firewall for port 25565 and my internal ip is the same on my routers page. But when I opened those ports there is an option in my router to open the same or different internal ports. I made it open internal port 25565, is that correct?

Share this post


Link to post
Share on other sites

Yes that's correct. Personally I'd try disabling your software firewall entirely since your router already has a firewall built in. At the very least it rules out something.

 

Are you forwarding all connections or just UDP or TCP?

Share this post


Link to post
Share on other sites

Yes that's correct. Personally I'd try disabling your software firewall entirely since your router already has a firewall built in. At the very least it rules out something.

 

Are you forwarding all connections or just UDP or TCP?

When you say software firewall are you talking about the firewall windows has or a firewall I installed manually?

 

And yes I forwarded for UDP and TCP.

Share this post


Link to post
Share on other sites

Just disable all firewalls on your computer (Windows Firewall, and anything else you've installed) to troubleshoot whether a software firewall is blocking the connection or not.

Share this post


Link to post
Share on other sites

When you say software firewall are you talking about the firewall windows has or a firewall I installed manually?

Both.

 

Although if people on your LAN can join your game it's definitely something to do with your router configuration (I would assume if it's firewall related LAN connections would be blocked too). If you're 100% positive you have the right external IP address then I'd look through your router for something that may be amiss.

Share this post


Link to post
Share on other sites

Both.

 

Although if people on your LAN can join your game it's definitely something to do with your router configuration (I would assume if it's firewall related LAN connections would be blocked too). If you're 100% positive you have the right external IP address then I'd look through your router for something that may be amiss.

Here is a screenshot of my router page and cmd showing my internal ip. And yes I checked the external port using http://www.yougetsignal.com/tools/open-ports/ . its still closed even with firewall disabled =(

post-72478-0-10674100-1333390765_thumb.png

Edited by stackrainer

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...