Jump to content
Sign in to follow this  
htaed

odd ram issue with a laptop

Recommended Posts

I bought a friend of mine some more ram for his laptop for Christmas and whenever we install the new ram the screen wont turn on it sound like the laptop powers up but nothing. his mobo does support 8 gigs of ram through some searching it looks like a brand issue i bought corsair thinking it would work. anyone else heard of this is it possible it actually is just a brand issue its the same clock speeds and everything. or any ideas what it could be. we did try 1 stick at a time in each slot and still nothing. when old ram is put back it runs just fine.

hes got a toshiba qosmio x305-q705 thanks in advance

Share this post


Link to post
Share on other sites

Sounds like you got too much RAM.

 

What RAM did you buy and what is its overall memory capacity?

 

...his mobo does support 8 gigs of ram...

What made you come to this conclusion?

 

It says that it can support only a maximum of 4 GB RAM on the toshiba website.

Edited by Alexandre

Share this post


Link to post
Share on other sites

yeah on toshiba's website it says 4gb but when you look up the chip set etc. it says 8gb also on multiple forums i have read of successful upgrade to 8gb of ram in this laptop. http://forums.toshiba.com/t5/Qosmio-Laptops/Qosmio-X305-Q705-RAM/td-p/44696 just one i found. dont feel the need to post many. but is that what happens when too much ram is installed? im thinking maybe a bios setting or even bios upgrade may be required or something of that nature.

Share this post


Link to post
Share on other sites

yeah on toshiba's website it says 4gb but when you look up the chip set etc. it says 8gb also on multiple forums i have read of successful upgrade to 8gb of ram in this laptop. http://forums.toshiba.com/t5/Qosmio-Laptops/Qosmio-X305-Q705-RAM/td-p/44696 just one i found. dont feel the need to post many. but is that what happens when too much ram is installed? im thinking maybe a bios setting or even bios upgrade may be required or something of that nature.

 

For a company to officially state that the Laptop is only capable of handling 4gb of ram and then to have people put in 8 GB, it sounds like a BIOS update came out after the official documents were issued. I would update the BIOS and see what happens. Make sure your ram is rated at 1066. I am sure you have already done that, but just in case you are prone to simple mistakes, you might want to check. Lastly, it is always possible that both ram sticks were DOA. This would be rare, but possible.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×