Jump to content

Firmware Update Help on OCZ Vertex 3


unknown_error
 Share

Recommended Posts

Hello and thank you for taking the time to read my post. I have recently upgraded to a second Vertex 3 and need to update the firmware on the drive that does not have windows installed on it. I downloaded the toolbox and when I tried to update the firmware I got as far as "Firmware Download Complete" and then it does nothing. It doesn't update the firmware it just downloads it. Any suggestions as to how I can get this setup?

Share this post


Link to post
Share on other sites

Yes, I have two. I have a 60 gig (OS Drive) and a 120 gig (gaming drive). I'm trying to update the 120 gig. I've looked everywhere for an update guide but it seems I'm the only one that doesn't know how to do it because I couldn't find one. If I cant do it from within a windows environment then how can I?

Share this post


Link to post
Share on other sites

Delete any partitions on the drive, Secure erase the drive then roboot-----> Open the toolbox---> then update the firmaware on your selected drive------> Reboot then it should be updated. :cheers:

 

It won't let me secure erase, it says the drive is frozen. I tried to secure erase with it online and offline and neither worked. The drive is being read by windows so its not a detection issue.

Share this post


Link to post
Share on other sites

Hey, thanks for all the replies but I did end up finding the problem. I guess the drives have to be in AHCI in order to do the update and I had them in IDE. So after several loads of windows later everything is up and running lickity split. Once again thanks for the help.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...