Jump to content
Black64

Need some tech support

Recommended Posts

OK, so I was tasked at work to fix a HP Pavilion Slimline s7420n PC. The issue was the HDD was clicking and it wouldn't boot, So I ordered a new HDD and tried to install XP. I couldn't get it to install. The error was reboot and select proper media device or insert boot media device and press a key. I still can't get it to boot.

 

Here is what I have tried so far

1.new HDD

2.Format drive using a different PC

3.tried to install XP

4.tried to install 7

5.Put HDD in another PC, installed 7 and put the HDD back into the HP, still won't boot

6.Checked all cables

7.Changed boot order in BIOS

8.Checked if everything is seen in BIOS

 

Other info

HDD is SATA

CD/DVD is PATA

 

 

Right I think it's the Mobo/BIOS is the issue and any help is great. :thx:

Edited by Black6464

Share this post


Link to post
Share on other sites

There is a bit of a catch with the pavilions. I was working at a computer store, and we had a similar problem. Tried three new HDD's before it worked and the only thing we could glean from the trial an error process was that the hard drive that did work was western digital (the same manufacturer of the drive we were replacing). The rest of the other hard drives were seagate and samsung. We tested each one and they all worked in a different system, but for some odd reason they would not post for the boot drive for that PC.

 

I don't know if the hard drive has to be the same company or not. However, I would test that theory out on your problem. If it does work then great. If not, it is either a bad sata port(s), a bad motherboard, or a bad sata cable.

 

One last thing to do is make sure the bios is in IDE mode with the submode set to compatible.

Share this post


Link to post
Share on other sites

There is a bit of a catch with the pavilions. I was working at a computer store, and we had a similar problem. Tried three new HDD's before it worked and the only thing we could glean from the trial an error process was that the hard drive that did work was western digital (the same manufacturer of the drive we were replacing). The rest of the other hard drives were seagate and samsung. We tested each one and they all worked in a different system, but for some odd reason they would not post for the boot drive for that PC.

 

I don't know if the hard drive has to be the same company or not. However, I would test that theory out on your problem. If it does work then great. If not, it is either a bad sata port(s), a bad motherboard, or a bad sata cable.

 

One last thing to do is make sure the bios is in IDE mode with the submode set to compatible.

 

Thanks, the HDD I am using is a Seagate, The one I pulled out was a WD :blink: . I tested the sata cable and it's fine. I probably will end up just ordering a new PC thou. :P

Edited by Black6464

Share this post


Link to post
Share on other sites

Thanks, the HDD I am using is a Seagate, The one I pulled out was a WD :blink: . I tested the sata cable and it's fine. I probably will end up just ordering a new PC thou. :P

 

I bet that is the problem, I don't understand why HP would do that? Don't order a new pc, build one. There are some really good kit prices with tiger direct right now, and it would be way cheaper than buying a new one.

Share this post


Link to post
Share on other sites

Does the bios have a setting for boot drive? This would be in addition to the boot order selection. If you have two drives make sure only the boot drive is connected.

Share this post


Link to post
Share on other sites

I bet that is the problem, I don't understand why HP would do that? Don't order a new pc, build one. There are some really good kit prices with tiger direct right now, and it would be way cheaper than buying a new one.

 

I just will buy a super cheap one on ebay. my budget is only like 50-100 bucks :teehee:

 

 

Does the bios have a setting for boot drive? This would be in addition to the boot order selection. If you have two drives make sure only the boot drive is connected.

 

Yes that is the only HDD in it.

Share this post


Link to post
Share on other sites

I just will buy a super cheap one on ebay. my budget is only like 50-100 bucks :teehee:

 

 

 

 

Yes that is the only HDD in it.

Hey there is this guy DNAngle I think is his screen name. He has a few computer he is trying to sell. Why not see what he has to sell?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...