Jump to content
NerdGoneWild

Just finished my first build!

Recommended Posts

So after much research (mainly from this site and newegg reviews) I have completed my build. I am not sure if I need to do anything in particular to make the computer run more efficiently or better but if anyone has advice I always appreciate it.

I mainly built this computer for gaming but I wanted to be able to do more stuff if i ever decided to.

the build consists of:

case: HAF 932 advanced

mobo: Asus P8P67 deluxe

CPU: Intel i7 2600k

PSU: corsair HX850W

Memory: G skill ripjaw X 8gb (4x2) 1600

Graphics: Geforce XFX 8500gt (only part I cant afford atm, getting GTX 4 or 5 series next month)

HDD: Western digital black 1tb

Drive: samsung writer

OS: Windows 7 Ultimate

Monitor: old dell 19"

 

002.jpg

Cannonpicsupto5-21299.jpg

007.jpg

0042.jpg

009.jpg

0062.jpg

006.jpg

hafinterior1.jpg

 

I had a ton of fun during this build and was so happy to see it come together, but I will admit it was very stressful. Especially having to RMA my first board...

 

Is there any specific things I should do now that it is finished? I put in the disc that came with the mobo and installed all drivers it had, other then that I didn't do anything. I also never pressed the mem ok button on motherboard since from what I read it is to be used if the ram isn't being acknowledged?

Share this post


Link to post
Share on other sites

Looks great, excellent choice on components! :thumbsup: I would recommend flashing the BIOS to the latest version, and also to get the latest and greatest versions of the drivers from Asus, usually the drivers off the CD are outdated. After that I would also do some stress testing to make sure the system is "stock stable".

Edited by Ts631

Share this post


Link to post
Share on other sites

Congratz That reminds me I never posted pics of my finished 2nd build :P

 

How do you like the sabertooth man, I had it in the cart and was going to purchase but had read some horror stories on its rebooting problems? Was my second choice though. and post some pics up now, it's never too late and everyone loves pictures :P

Share this post


Link to post
Share on other sites

Nice build, now just add a decent cooler and crank her up !

 

haha yeah, I am going to get the 212 cooler I was thinking since I don't plan on going past 4ghz. Should I even go to 4ghz since I just will be gaming? I don't want to hurt anything! :P

My cpu temp is currently around 50-60 while using the internet and figuring all this stuff out.

 

btw I want to do this 'stress test' to make sure everything is safe, except this dreaded code AA, how would I go about doing this? Also finding all the drivers I need?

Share this post


Link to post
Share on other sites

man thats pretty sweet looking, it would be even more amazing with a Blue fan in there instead of the red one, and why the heck did they make all those red leds on the completely blue MB, if only there were a way to make them blue!

Share this post


Link to post
Share on other sites

man thats pretty sweet looking, it would be even more amazing with a Blue fan in there instead of the red one, and why the heck did they make all those red leds on the completely blue MB, if only there were a way to make them blue!

 

Lol, luckily all of the red lights from the motherboard are no longer on. That was during build when errors were coming up. Now just the amber AA code it on in there. and i did read an article on how to change the red LED from the case to blue. I just am very nervous about messing it up since I spent so much on all of this stuff! :) I might have someone else more qualified cut out the red led and solder in some blue ones.

Share this post


Link to post
Share on other sites

man thats pretty sweet looking, it would be even more amazing with a Blue fan in there instead of the red one, and why the heck did they make all those red leds on the completely blue MB, if only there were a way to make them blue!

 

hey I noticed you play a lot of everquest 2, me and my girl are currently looking for a fun mmorpg to play together. would you highly recommend EQ?

Share this post


Link to post
Share on other sites

The Sabertooth is a great board, I don't remember reading about any rebooting problems. I may have forgotten, This thing overclocks very well and I've had no trouble reaching 4.7Ghz.

 

Very Satisfied with my purchase, I actually wanted to get the Deluxe but it was sold out and more expensive lol.

Share this post


Link to post
Share on other sites

hey I noticed you play a lot of everquest 2, me and my girl are currently looking for a fun mmorpg to play together. would you highly recommend EQ?

yes i PLAYED alot of eq2, i don't play any more, I was pretty hardcore into it for a few years, then i decided to stop when several of my online friends stoped. It is a fun game, I enjoyed it alot, although I started to dislike it more and more towards the end as it became more and more wow-ish and super easy. eq1 was and still is probably the best mmorpg out there unfortunately the graphic in that game are maxed out buy a geforce ti200 which is like a 10 year old graphics card, so it's not much fun to look at. You can play EQ2 for free tho if you want to test it out they have free servers you can play on. just goto everquest.com and there should be a link on there some were to the free play server and game download. I think they mentione wow has like a new free play till lvl 20 thing now too, if you wanted to try it as well.

Share this post


Link to post
Share on other sites

The Sabertooth is a great board, I don't remember reading about any rebooting problems. I may have forgotten, This thing overclocks very well and I've had no trouble reaching 4.7Ghz.

 

Very Satisfied with my purchase, I actually wanted to get the Deluxe but it was sold out and more expensive lol.

 

lol yeah man, the deluxe was sold out when I went to frys and they were being very persistent on selling me the sabertooth, I most likely would have been happy either way. but I decided to wait it out and order from newegg once they got some in. Although my first board had VGA error so had to RMA.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×