Jump to content
Deathmineral

Firefox 5

Recommended Posts

Anyone here tried out the beta for firefox 5 yet? I keep getting the popup message for it, and it's really annoying. :lol: Seems a little soon to me, everyone hasn't even gotten onto Firefox 4 yet even.

Share this post


Link to post
Share on other sites

Wait, didn't they just release Firefox 4? I haven't even tried it myself. To busy using chrome........ :whistling:

Share this post


Link to post
Share on other sites

It's pretty much the same for Firefox 4, except with performance improvements. Firefox is now on a release major version every few months. Firefox 7 is already in the works.

Share this post


Link to post
Share on other sites

It's pretty much the same for Firefox 4, except with performance improvements. Firefox is now on a release major version every few months. Firefox 7 is already in the works.

 

They are trying to catch up to Microsoft! :lol: (Windows 7)

Share this post


Link to post
Share on other sites

I haven't tried the Beta5 yet. I ran the Beta4 and then the official release. I've been a FF user for years now, but after 4 I just dumped it all together. Strictly Chrome and IE9 now..................

Share this post


Link to post
Share on other sites

I haven't tried the Beta5 yet. I ran the Beta4 and then the official release. I've been a FF user for years now, but after 4 I just dumped it all together. Strictly Chrome and IE9 now..................

If it wasn't for add-ons I would probably do the same. Especially if they're going to be releasing new versions all the time now.

Share this post


Link to post
Share on other sites

If it wasn't for add-ons I would probably do the same. Especially if they're going to be releasing new versions all the time now.

:withstupid: If it wasn't for Ad-Block and NoScript on FireFox, I'd be using Chrome. (If there are similar versions of this on Chrome, by George, Tell me!)

Share this post


Link to post
Share on other sites

:withstupid: If it wasn't for Ad-Block and NoScript on FireFox, I'd be using Chrome. (If there are similar versions of this on Chrome, by George, Tell me!)

Like this?

 

Edit: There's also a Noscripts add-on, not sure if that's the same, I don't use the add-on.

 

Double Edit: Thanks for bringing up AdBlock for Chrome, I've actually been needing to install that and another add-on for chrome for a while now. :D

Edited by Deathmineral

Share this post


Link to post
Share on other sites

Not sure about NoScript for Chrome as I haven't researched that. But I'm using AdBlock for Chrome and Vanilla Cookie Manager for Chrome. IMHO these are two must have add-ons for the Chrome browser.

Share this post


Link to post
Share on other sites

Not sure about NoScript for Chrome as I haven't researched that. But I'm using AdBlock for Chrome and Vanilla Cookie Manager for Chrome. IMHO these are two must have add-ons for the Chrome browser.

I think noscript disables js as well, that ruins it. :down:

 

No i havent tried ff5, im still trying to figure out how to keep two stable releases co-existing side-by side, let alone three!

Share this post


Link to post
Share on other sites

If it wasn't for add-ons I would probably do the same. Especially if they're going to be releasing new versions all the time now.

Go to about:config. Right click and add a new boolean. Name it "extensions.checkCompatibility.nightly" if you run the Nightly builds (this is for FF7) and tell it false. Now all the add-ons work and I have not had a single problem with any of them. I've been running the nightly 64-bit build for months now, since before FF4 was released, and have just kept doing that, for the 64-bit. Of course it has cost me the ability to view Amazon Lightning Deals and the rolling news things on Newegg. Not sure what's up with Newegg, but from what I've read Amazon just has it stated somewhere not to work with these non-release builds and it isn't a Firefox thing. The Newegg issue is more likely to do with running the 64-bit Flash. You cannot use a 32-bit version of flash in the 64-bit Firefox, in case you were thinking that.

Anyhow, yes, I have been running FF7 or, more accurately, Nightly (it was FF6 and then it changed to 7 for some reason :dunno:). This is essentially the pre-alpha build while FF5, which goes by Aurora in the trunk, is more like an alpha. The Nightly builds will never become release builds while the Aurora builds are intended to become release. I hope that makes sense.

 

No i havent tried ff5, im still trying to figure out how to keep two stable releases co-existing side-by side, let alone three!

I've never had any problems. I can tell you that you cannot run two versions of Firefox at the same time, but I've not had issues with going from Nightly to FF4, as needed.

Edited by Guest_Jim_*

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×