Jump to content

ATI HD4890 Problem


Lipton
 Share

Recommended Posts

Hey,

I bought this video card a year ago, and it started to get too laggy at games like FIFA and Assassin's Creed 2 (not heavy games I mean).

I think it started after a half a year i bought it.. and they don't wanna replace me for a new one.. they say it's working well.. but it's not

I don't know what to do, I've done all the things that may cause that but nothing worked (reinstalled windows 7 and v.c drivers and even disk clean up and difragment.. i know it's not related)

The lag is starting when there is a little stress on the game..

Oh and I have to mention it it wasn't before.

 

Please help me I can't play any games I feel I spent my money for nothing

Share this post


Link to post
Share on other sites

The important thing is to try and get the dust out of the heatink. If it has a cover then you can try and take it off, but this may void the warranty. A lot of people use compressed air to clean out dust, you could try that if you have any.

Also what are the rest of your specs?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...