Jump to content

disk read error occurred. Press Ctrl+Alt+Del to restart


PruritusAni
 Share

Recommended Posts

Last night while busy being awful at Counterstrike I was on the receiving end of a massive BSOD. I scrambled for paper and pen to write some of the stuff down but the computer shut down before i could write down anything. I thought nothing of it, and decided to go to sleep instead. Tonight, upon an attempt to restart the computer I was greeted by this:

disk read error occurred. Press Ctrl+Alt+Del to restart

 

So I fired up the ol' Google machine and found out that this problem is one of those. No one seems to know what causes it, and furthermore no one seems to agree on how to fix it. I did find a lot of possible solutions and have tried some of them:

 

Things I've tried:

1) change the SATA port and cable for the drive, make sure it's still the boot disk in the BIOS and restart. ==> No DIce

2) reset BIOS to defaults, make sure the disk drive is the boot disk even if in port 4. CLRTC jumper action ==> I now get this:

DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER

 

So I obeyed the lovely error message and:

 

3) tried running Startup Repair and after it did its thing it said:

 

To restart immediately, click Finish. If repairs were successful, Windows will start correctly. If repairs were not successful, Startup Repair might run again to continue fixing your computer.

 

and clicking on the diagnosis and repair details found:

Number of repair attempts:1

 

Tests performed:

Check for updates

System disk test

Disk failure diagnosis

Disk metadata test

 

All completed successfully. Error code = 0x0

 

Root cause found:

The partition table does not have a valid System Partition.

 

Repair action: Partition table repair.

Result: Completed successfully. Error code = 0x0

 

This sounded pretty hopeful, so I hit finish to restart and removed the win 7 disk out of the drive. The computer starts, flashes the POST at me as it always does and presents me with a blinking cursor. That does nothing, typing anything at it doesn't do anything and the only key combination that works is CtrlAltDel.

 

So at this point I fire the win 7 disk up again, and try some other things:

4 ) try to run CHKDSK /R /P from a console i was able to start up in the repair. It tells me that /P is an invalid parameter so I try it with just /R

 

The type of the file system is NTFS. Cannot lock current drive. Windows cannot run disk checking on this volume because it is write protected.

 

I try it again without /R and it runs amazingly quickly, with:

 

3086 kb total disk space.

 

there was more to that output, but 3086 kb of total disk space coupled with X:\Sources> being my command prompt told me that it was not going to get me anywhere. So going down the list of crazy things to try from the internets:

 

5) try to run FIXBOOT from the console. I am told that fixboot doesn't exist.

 

6) try to run FIXMBR from the console. I am told that FIXMBR doesn't exist.

 

So I restart the machine again, and this time after the POST flashes through in its usual way I'm faced with the same blinking cursor from above.

 

I'm feeling pretty aggravated by this point so in an act of "maybe it'll work?":

 

7) I am now running Spinrite's level 2 on the disk over night.

 

I'll update in the morning upon waking, but in the meantime as I'd like to keep my drive I turn to you:

Have any of you battled this before? How did you fare in the battle? Any hints, tips, suggestions appreciated.

Edited by PruritusAni

Share this post


Link to post
Share on other sites

most of the time when you get those it is ram related...chances are you wouldnt have to do anything other than fix the ram....

 

Boot to memtest and run Test #5 for 20 passes minimum then try test #8 for the same amount. If at anytime you get any errors STOP the test and try 1 stick at a time or try adding voltage....

Share this post


Link to post
Share on other sites

Well SpinRite said this:

 

A critical error occurred at: 5672 from which SpinRite CANNOT recover. The system has been halted.

 

I suppose Ill try and see if it gets seen on my mom's machine, and if that doesn't work I'll try memtest too as the very last attempt at not losing the disk.

Share this post


Link to post
Share on other sites

Well I've got memtest going now, doing the passes of 5, and I'll set it up to do the 8s while I'm at school. If I remember correctly those take longer, so by the time I get back they'll be done. I'll let you know how it works later tonight. Thanks for the help by the way. :cheers:

Share this post


Link to post
Share on other sites

UPDATE: Well I came back home and memtest ran a bunch of tests 5 and 8 while I was at school finding no errors. So the memory is not at fault here, leaving me with the last option of trying the drive in my mom's computer.

 

As an interesting aside I found some info on this 5672 error thrown by SpinRite:

 

Just to let folks know that may come across this error. So, I figured out the problem! Keep a close eye on the cylinder counter in the second screen. You'll notice that once it hits 65535 it crashes on the next count! The storage register used in SpinRite for the cylinder counter is 16 bits wide. So, in disks with cylinder counts greater than 64k (2^16) will fail with this error! It is such a small fix in the program that I'm shocked that no update has been released. Specially with the typical sizes of HDD these days. Shame on you Steve Gibson and the GRC folks!

 

So as it turns out this error doesn't really mean much in the way of the disk's health. So now I must find a program that does the job SpinRite was supposed to do, but right. Do you have any recommendations?

 

I'll update again after dinner and the attempt involving mom's computer.

Share this post


Link to post
Share on other sites

Iv been a tech of over 14 years bud. Bad Hard Drive guaranteed.

 

as for testing. what hard drive do you have? WD, Seagate, etc. try their software.

 

but im giving telling you its the HD.

 

 

Have to agree with this... sounds like you need to try to clone that thing to a new drive if it's not to late.

Share this post


Link to post
Share on other sites

well while trying to do all sorts of last minute things i decided i'd throw in a flash drive with xubuntu on it. From xubuntu (10.04) I decided i'd inspect the drive in question using 2 different utilities: Disk Utility and GSmartControl. Upon a quick test both report the drive is just fine, no errors nothing!! I've even went to run a read only benchmark which it did quite well in, no errors here either!

 

 

Finally I transplant it into mom's computer where upon being run as the boot drive it produces the same blinking cursor that does nothing. :pfp:

When I use mom's drive as the boot, it recognizes it, and proceeds to tell me that I need to format the disk before using it.

 

So I suppose at this point I admit defeat, but I'd like to reclaim my data from it. I'll experiment with a few things but I can't say I'm too hopeful at this point.

 

 

This is definitely one of the weirdest and maddening errors I've ever encountered. I just wish I knew what I did, so I can avoid doing it again.

 

 

 

UPDATE: I tried Active Partition Recovery, had it fix the boot sector on the drive and it seemed to have done something! I now can access that drive on my mom's computer. My computer on the other hand is unmoved, so it's displaying that blinking cursor still when I try to boot from it.

 

So I decided to connect my backup drive to mom's computer as well, to recover all of my stuff. Nevertheless this drive is also broken?!?!? and a scan by partition recovery revealed 4 partitions labeled Bad, Very Bad, Very Bad and Very Bad. I am now running a long scan to see if maybe i can recover it. More later

 

 

 

UPDATE 2: Well it seems as though i am able to recover files off the drive. There is however a catch: they are not at all labeled by their original names but instead are called things like:

 

Recovered mp3 file 41743836836969.mp3

Recovered text file 2491239478129.txt

 

and so on. There seems to be no folder structure left, and everything is piled together haphazardly in the Lost Files folder.

 

This of course is going to make the recovery process near to impossible, as I'd have to rename a trillion things over the course of the next few years. I'd be better off not even worrying about it at this point.

 

I found a few externals that had a good portion of the files/folders on there, and i have access to the boot drive, which had a good portion of the back up stuff on there.

 

I guess I'll reinstall windows 7 on the new drive I ordered today and hope that i'll never have to deal with this sort of nonsense again.

 

Thanks all for your help.

Edited by PruritusAni

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...