Jump to content

Sabertooth X58 troubleshooting.


Recommended Posts

Alright so I have the wierdest issue with my new build. I've got a Sabertooth X58 motherboard, i7 950 cpu, and Patriot Viper Extreme 2000 mhz RAM (I also have a cheap, compatibly listed stick as a tester).

 

Background: After the build was complete I turned it on for the first time and got no display. My only indication of an issue was the DRAM_LED. I tried all my sticks of RAM in every slot with no luck. I reset CMOS, changed the PCI-E slot of my GPU, checked all pins, remounted fan and reseated CPU etc. Still had the same issue. I tried the memOK! button but no matter how long I held it down the DRAM_LED would not start blinking like it was supposed to - however the CPU_LED came on while I was holding down the memOK! switch. Oh, and the board did POST with no RAM in, I got 1 long + 2 short beeps as I was supposed to. I recently RMA'd the motherboard since I was at a dead end and to my dismay I had the same issue. All of a sudden earlier I tried the memOK! switch again and after about 15 seconds of holding I just said screw it and let go, and then the DRAM_LED started blinking, the computer booted and I got into the BIOS. I checked the hardware settings and the CPU was running at 39 Celcius.. Unfortunately I didn't check what the RAM was running at. While installing Windows the computer restarted once, no problem. It restarted again and then froze at the Sabertooth X58 image. I force shut down and rebooted and the CPU_LED was on so I cursed a few times and switched off the PSU. I reset the CMOS and the CPU_LED went away and the DRAM_LED came back. Now no matter how hard I try (I've literally been trying for an hour) I can't seem to get the memOK! switch to get the DRAM_LED to blink. I took off my Coolermaster Hyper-212 plus since I thought the backplate might be shorting the mobo and installed the stock cooler, and that didn't fix anything. Again, I post with no RAM in. Some other info - I have 9 standoffs in the proper places, I think the screws I used may have been too large but I'm pretty positive this isn't a problem (no sign of shorting or anything of that sort - and if it was I don't think I could have gotten BIOS anyway).

 

 

While I'm sorry for the wall of text, I'd REALLY like to get this solved. Hopefully some wiz out there has a suggestion on what to do. I have a new CPU coming in a few days but I'm skeptical that this will solve the issue (I went with this option because of the fact that when I hold down memOK! the CPU_LED comes on, possibly indicating that it can't get past the memory controller in the CPU). Anyway, whoever can help me fix this problem wins 100 internets. Thanks in advance.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...