Jump to content

random hibernation


Savan

Recommended Posts

so for the last 2 weeks or so, my computer has randomly started hibernating. I've never had hibernation enabled, or sleep mode for that matter. I use my system for folding, so its really annoying to have to keep checking that its still running.

 

I have everything set to not sleep, or hibernate, in the power management, and I have hybrid sleep disabled.

 

I tried goggling it, and found some instructions for the cmd prompt that disabled hibernation completely, but now it's going into sleep mode instead.

 

any idea why its doing this or how to make it stop.

 

Windows 7 Home 64 bit

Share this post


Link to post
Share on other sites

Savan,

 

Are you using the Balanced or High Performance Power profiles in Windows 7?

 

In addition to checking your event logs as suggested by hardnrg - also take a look at your task scheduler library and make sure one of your applications or programs hasn't scheduled a time out, sleep or hibernation trigger.

Edited by wevsspot

Share this post


Link to post
Share on other sites

I had it set to custom, but I switched to high performance. I looked in the event viewer, but I didnt see anything that jumped out at me. If it happens again, I'll take a look so I have a defined time window to look through.

Share this post


Link to post
Share on other sites

it just happened this morning. I checked the event viewer and it said

 

Kernel Power

Event ID 41

Task Category (64)

 

The System is Entering Sleep

 

Reason for Sleep: Battery

 

My ups was supplying power for about 30 seconds. In power options I have it set not to sleep on battery

 

 

 

:EDIT: I think I figured it out. In the battery setting of power manager it says critical level 98% and critical action is hibernate. It must be sleeping because I disabled hibernate in the command line

 

:DOUBLE EDIT: It wont let me change the critical level. I can type in a number or change it with the up and down arrows but when I click apply it always goes back to 98%

Share this post


Link to post
Share on other sites

  • 2 months later...

I just fixed this problem on my pc.

 

You need to run an elevated command prompt and use "powercfg".

 

I can't find the exact page I found which helped me, but if you run "powercfg /query" and post back the results here, i'll tell you the command line that you need to enter.

 

Steve

Share this post


Link to post
Share on other sites

I just fixed this problem on my pc.

 

You need to run an elevated command prompt and use "powercfg".

 

I can't find the exact page I found which helped me, but if you run "powercfg /query" and post back the results here, i'll tell you the command line that you need to enter.

 

Steve

The GUID's needed in the powercfg command to fix the "critical level stuck at 98%" problem are unique to your hardware, so it's no use just giving you the command line I entered.

 

By running "powercfg /query >powercfg.txt" you can dump the information to a text file, which will contain all of the GUID's and sub-GUID's needed to work out a command line specific for your machine.

 

Steve

Share this post


Link to post
Share on other sites

The GUID's needed in the powercfg command to fix the "critical level stuck at 98%" problem are unique to your hardware, so it's no use just giving you the command line I entered.

 

By running "powercfg /query >powercfg.txt" you can dump the information to a text file, which will contain all of the GUID's and sub-GUID's needed to work out a command line specific for your machine.

 

Steve

 

 

 

here is the relavent info from the txt file created

 

Subgroup GUID: e73a048d-bf27-4f12-9731-8b2076e8891f (Battery)

 

Power Setting GUID: 637ea02f-bbcb-4015-8e2c-a1c7b9c0b546 (Critical battery action)

Possible Setting Index: 000

Possible Setting Friendly Name: Do nothing

Possible Setting Index: 001

Possible Setting Friendly Name: Sleep

Possible Setting Index: 002

Possible Setting Friendly Name: Hibernate

Possible Setting Index: 003

Possible Setting Friendly Name: Shut down

Current AC Power Setting Index: 0x00000000

Current DC Power Setting Index: 0x00000001

.

.

.

 

Power Setting GUID: 9a66d8d7-4ff7-4ef9-b5a2-5a326ca2a469 (Critical battery level)

Minimum Possible Setting: 0x00000000

Maximum Possible Setting: 0x00000064

Possible Settings increment: 0x00000001

Possible Settings units: %

Current AC Power Setting Index: 0x00000005

Current DC Power Setting Index: 0x00000062

Share this post


Link to post
Share on other sites

here is the relavent info from the txt file created

 

Subgroup GUID: e73a048d-bf27-4f12-9731-8b2076e8891f (Battery)

 

Power Setting GUID: 637ea02f-bbcb-4015-8e2c-a1c7b9c0b546 (Critical battery action)

Possible Setting Index: 000

Possible Setting Friendly Name: Do nothing

Possible Setting Index: 001

Possible Setting Friendly Name: Sleep

Possible Setting Index: 002

Possible Setting Friendly Name: Hibernate

Possible Setting Index: 003

Possible Setting Friendly Name: Shut down

Current AC Power Setting Index: 0x00000000

Current DC Power Setting Index: 0x00000001

.

.

.

 

Power Setting GUID: 9a66d8d7-4ff7-4ef9-b5a2-5a326ca2a469 (Critical battery level)

Minimum Possible Setting: 0x00000000

Maximum Possible Setting: 0x00000064

Possible Settings increment: 0x00000001

Possible Settings units: %

Current AC Power Setting Index: 0x00000005

Current DC Power Setting Index: 0x00000062

 

I also need the Power Scheme GUID, at the very top of the file you created.

 

Without machine specific GUID's, you enter:

powercfg -setdcvalueindex [Power Scheme GUID] [subgroup GUID] [Power Setting GUID] [value]

(Where the GUID's in square brackets are from the file that "powercfg -query >powercfg.txt" created). The [value] at the end is the value you wish to set to - in this case it's a percentage.

 

The values we have for your command so far are:

Power Scheme GUID: ?

Subgroup GUID: e73a048d-bf27-4f12-9731-8b2076e8891f

Power Setting GUID (Critical battery level): 9a66d8d7-4ff7-4ef9-b5a2-5a326ca2a469

DC Value (in %:): 05%

 

Your command line so far is:

powercfg -setdcvalueindex ? e73a048d-bf27-4f12-9731-8b2076e8891f 9a66d8d7-4ff7-4ef9-b5a2-5a326ca2a469 05

 

If you just cut and paste your "Power Scheme GUID" over the question mark, enter it into an elevated (run as administrator) command prompt and your problem will be fixed.

 

Let me know how it goes and please give me some +rep if I have helped.

 

Steve

Edited by KissMyWookie
  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...