Jump to content
Sign in to follow this  
lost

i think i killed my dad's PC

Recommended Posts

it kinda slid of its elevated platform and the front bottom corner fell an inch. now whenever i try to start it up, i'l just beep at startup and won't boot up. i tried a few setups:

1) just have the motherboard connected to the power supply. nothing happened.

2) motherboard+video card+ram. nothing

3) motherboard+video card+ram+HD. nothing

4) same as 3, but with the cpu this time. it starts beeping.

 

would it be safe to assume i messed up the cpu when the front edge of the comp dropped an inch?

Share this post


Link to post
Share on other sites

Completely OT but on the forum frontpage this thread is shortened to

# In: i think i killed my dad...

 

It got me worried for a while.

 

Correct me if I'm wrong but the beep pattern should indicate what is wrong, shouldn't it?

Share this post


Link to post
Share on other sites

Check the heatsink and make sure it did not pop loose, reseat the memory

 

send it to me, i'll fix it for not to much money....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...