Jump to content
daniel

switch + router = no connection

Recommended Posts

Okay here is my current setup

Internet -> Router ->(PC's, Switch) ....switch ->PCs and another router

 

my issue is the following when ever i connect the switch to the primary router i lose my internet connection and also i cant access the router itself, i use to havethis same setup but with second router going before the switch but it was a bottle neck b/c the router did not work at 1000mbits/s

 

my router is a dlink dgl-4500, my swtch is a dling dgs-1008D, im not sure where im going wrongbut everyhing collapses once i connect the cable

 

any help is appreciated

thanks

dan

Share this post


Link to post
Share on other sites

I don't have those routers but my first thought is to make sure that the top most router is giving out ip addresses and only that one.

Share this post


Link to post
Share on other sites

make sure DHCP is disabled on the 2nd router....I'd just get a bigger switch...

 

I have a Trendnet 8-port switch and I love it...

Share this post


Link to post
Share on other sites

I would connect it as Modem - Router (PCs) - Router (PCs) - Switch. Disable DHCP on second router.

 

Configure seperate IP addresses for the router. For example, mine:

Modem : 192.168.0.1

Router 1: 192.168.1.1

Router 2: 192.168.1.2

Switch: N/A (Just connect to any available port).

 

Make sure the two routers are connected to each other. All Linksys and 1 generic hub for me.

Share this post


Link to post
Share on other sites

I would connect it as Modem - Router (PCs) - Router (PCs) - Switch. Disable DHCP on second router.

 

Configure seperate IP addresses for the router. For example, mine:

Modem : 192.168.0.1

Router 1: 192.168.1.1

Router 2: 192.168.1.2

Switch: N/A (Just connect to any available port).

 

Make sure the two routers are connected to each other. All Linksys and 1 generic hub for me.

 

before you go spending a ton of money make sure the cables/rj45's are good...crappy cables/connections cause all kinds of problems.....even if you believe with all your heart they're good, test 'em....switch to router should be a crossover cable, not a straight thru...

Share this post


Link to post
Share on other sites

As others have said, the issue is going to be related to DHCP. Make sure it is only enabled on the router connected to the modem.

Also ensure that each router has a unique IP, and that this IP is NOT part of the DHCP pool (most routers default address is 192.168.0.1, if both routers occupied this address, you would get no internet)

 

The order in which they are connected plays no effect. Unless you are using the WAN port of the second router.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...