Jump to content
Sign in to follow this  
Jump4h

5970 Build Log

Recommended Posts

So about a week ago I built my computer, and thought I'd share the build process with you guys.

 

Antec 1200

Gigabyte UD-7

XFX 5970 BE

Core i7 930 @ stock for now

Cooler Master V8

Corsair 6GB 1600MHz

Antec CP-1000

Corsair Nova 128GB SSD

WD Green 1,5 TB

TV Card

Creative X-Fi Titanium Pro series

 

Razer Mamba

Logitech G15 v2

Sennheiser PC-350

Logitech X-540

3x Samsung T260 25.5"

 

Using this adapter: http://accessories.us.dell.com/sna/products/cables/productdetail.aspx?c=us&l=en&s=dhs&cs=19&sku=330-5521

 

Update 24.7 : PSU would lose power after 5 seconds of boot. Replacement acquired from retailer.

Update 25.8 : Added 9800GT PhysX Card.

 

28028614.th.jpg

97813236.th.jpg

42208675.th.jpg

49041136.th.jpg

44113004.th.jpg

51130442.th.jpg

35496236.th.jpg

71006947.th.jpg

48735315.th.jpg

33456648.th.jpg

Edited by Jump4h

Share this post


Link to post
Share on other sites
what? nice equipment but your in some seriiiiiiious ned of cable management lol...

Thats what I said but the final version wasn't so bad.

Share this post


Link to post
Share on other sites
what? nice equipment but your in some seriiiiiiious ned of cable management lol...

I think I did a pretty decent job; do you mean the picture where I hadn't connected any cables and done any cable management?

 

What?

 

:DDD

Edited by Jump4h

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...