Jump to content
Sign in to follow this  
Fricken Hamster

Mah turbo boosting won't work

Recommended Posts

So I have the i5 and the G.Skill RAM. My mobo, Gigabyte p55ud4p, had lax timings on my RAM, so I tightened it, but now my turboboositing doesn't work. :< Can someone help me?

Share this post


Link to post
Share on other sites

If the power saving settings are enabled (C states), Turbo will only kick in as needed -- if it idles under 2 GHz, that's normal. Try running a single-threaded application (SuperPi for example) and you should see the frequency bump up to 3.something GHz.

Share this post


Link to post
Share on other sites
If the power saving settings are enabled (C states), Turbo will only kick in as needed -- if it idles under 2 GHz, that's normal. Try running a single-threaded application (SuperPi for example) and you should see the frequency bump up to 3.something GHz.

 

hmm, I have the intel turbobooster monitor, and it shows a big red cross saying my turboboosting is disabled.

 

Actually, it might be because I updated my BIOS

Edited by Fricken Hamster

Share this post


Link to post
Share on other sites

Just disable turbo boosting altogether and lock the turbo cpu multiplier (x21 for an i5-750) in bios. There you go, permanent turbo mode ;)

 

I know my gigabyte p55a-ud4p can do this, so yours should too :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...