Jump to content

ATI 4890 Toxic Crossfire Problem


Zlmo51

Recommended Posts

Ive got a Problem Running my Crossfire Setup at Dual x16.

 

I have Two Sapphire 4890 Toxic Cards on a ASUS Crosshair III Formula Bios latest 1301. According to ASUS the Board has 2 PCI-E x16 Slots which can run @ x16 Dual Crossfire

 

my other specs

AMD P2X4 965 C3

2 GB Kingston 1333

3x 1 TB Samsung HDD

My OS is Windows XP Pro 64-Bit ,on the latest Catalyst 9.12

 

My Primary Adapter runs at Proper PCI-E 2.0 x16 According to ATI Control Center,

The Secondary Adapter only Runs at PCI-E 2.0 x4.

 

GPU-Z also Says Link Width is x4 but x16 capable , and i couldnt find an Option in the Driver Menues to change this.

 

The Mainboard Manual has a Chapter for Bios of PCI-E Watts Configuration Peer 2 Peer Link etc. but in my 1301 Bios this Option is Missing.

I also havent found any similar option that could be relevant to this problem.

 

Now im waiting on a Reply from ASUS Support Staff, for now im just waiting to see if anyone can help me fix this some other way

Anyone got any ideas ?

Share this post


Link to post
Share on other sites

Yep the Cards are in the right slots, there are only two (Blue) PCI-E 2.0 Slots.

 

post-70564-1264450200_thumb.jpg

 

Here is a review of the board OCC Review with pictures etc.

 

Can i really use two crossfire bridges ? i have only one connected right now, didnt know you could have (need) two.

 

I just got an answer from ASUS Support, they Sent me a new BIOS 1403 (not out yet ^^), told me to Clear CMOS, remove battery load Default setup Settings. Maybe that will help gonna try now.....

 

Im also gonna try the DUAL Crossfire Bridge Configuration. (i hope its safe to do so)

Share this post


Link to post
Share on other sites

Well the BIOS update didnt change anything , the Two Crossfirebridge option also didnt change anything :(

 

Well atleast nothing bad happend, in my catalyst driver menue the Primary Adapter is active with x16 the Secondary adapter is DISABED with x4 anyone know if this is normal for crossfire ?

Share this post


Link to post
Share on other sites

Isn't there an option in the bios to set the slot configuration? I know my bios has this option.

 

Nope there used to be an option in the BIOS but its been removed in the latest builds according to ASUS the PCI-E Solt configuration doesnt need to be set manually in order to function prooperly

Share this post


Link to post
Share on other sites

  • 1 month later...

Sorry if this is problem is already resolved, but I had the same problem with a single 4890 Toxic and it only read as PCI-E 2x, after I moved it to another 16x PCIE slot (using MSI 790FX-GD70, which uses 2 16x slots and 2 8x slots). All I had to do was take it out and reseat it on the same slot f0r it to read 16x again.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...